vbgl Vincent Laporte
github.com/vbgl · maintains 464 packages (463 directly), sole maintainer of 388, member of 0 teams
464 packages · page 3 of 5
| Package ▲ | Version | Maintainers | # | Teams | Deps | Used by | Used by (transitive) | Status |
|---|---|---|---|---|---|---|---|---|
Minimal OCaml library providing hexadecimal converters |
1.5.0 |
1 | 6 | 14 | 74 | single | ||
CoHTTP implementation using the Lwt concurrency library |
6.3.0 |
1 | 5 | 3 | 37 | single | ||
HTTP client for MirageOS |
0.0.11 |
1 | 13 | 1 | 1 | single | ||
High-performance, memory-efficient, and scalable web server for OCaml |
0.7.1 |
1 | 9 | 4 | 4 | single | ||
Lwt support for http/af |
0.7.1 |
1 | 8 | 1 | 1 | single | ||
High-performance, memory-efficient, and scalable HTTP library for OCaml |
0.2.0 |
1 | 10 | 3 | 11 | single | ||
EIO support for httpun |
0.2.0 |
1 | 7 | 1 | 1 | single | ||
Lwt support for httpun |
0.2.0 |
1 | 9 | 1 | 5 | single | ||
Lwt + Unix support for httpun |
0.2.0 |
1 | 7 | 1 | 4 | single | ||
Common HTTP/1.x types |
0.2.0 |
1 | 6 | 3 | 30 | single | ||
Websocket implementation for httpun |
0.2.0 |
1 | 12 | 4 | 7 | single | ||
Lwt support for httpun-ws |
0.2.0 |
1 | 9 | 0 | 0 | single | ||
Image formats such as PNG and PPM in OCaml |
20221222 |
1 | 8 | 0 | 0 | single | ||
Platform-agnostic multi-level index |
1.6.2 |
1 | 19 | 1 | 2 | single | ||
Bindings for Linux’s filesystem monitoring interface, inotify |
2.6 |
1 | 8 | 1 | 2 | single | ||
Various signed and unsigned integer types for OCaml |
0.8.0 |
1 | 6 | 7 | 73 | single | ||
IO memory page library for Mirage backends |
3.0.0 |
1 | 9 | 5 | 8 | single | ||
IRI (RFC3987) native OCaml implementation |
1.2.0 |
1 | 8 | 1 | 6 | single | ||
Distributed database built on the same principles as Git |
3.11.0 |
2 | 23 | 9 | 11 | maintained | ||
Irmin backend which allow to store values into chunks |
3.11.0 |
2 | 11 | 0 | 0 | maintained | ||
Mergeable Irmin data structures |
3.11.0 |
2 | 13 | 0 | 0 | maintained | ||
Generic file-system backend for Irmin |
3.11.0 |
2 | 12 | 1 | 1 | maintained | ||
Git backend for Irmin |
3.11.0 |
2 | 24 | 1 | 1 | maintained | ||
GraphQL server for Irmin |
3.11.0 |
2 | 16 | 1 | 1 | maintained | ||
MirageOS-compatible Irmin stores |
3.11.0 |
2 | 9 | 2 | 2 | maintained | ||
MirageOS-compatible Irmin stores |
3.11.0 |
2 | 17 | 0 | 0 | maintained | ||
MirageOS-compatible Irmin stores |
3.11.0 |
2 | 12 | 0 | 0 | maintained | ||
Irmin backend which stores values in a pack file |
3.11.0 |
2 | 20 | 1 | 1 | maintained | ||
Irmin test suite |
3.11.0 |
2 | 21 | 5 | 7 | maintained | ||
Portable Irmin watch backends using FSevents or Inotify |
0.5.0 |
1 | 9 | 3 | 5 | single | ||
ISO 8601 and RFC 3999 date parsing for OCaml |
0.2.5 |
1 | 5 | 5 | 10 | single | ||
Library that parses Java .class files into OCaml data structures |
3.2.2 |
1 | 7 | 1 | 2 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 14 | 39 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 11 | 7 | 312 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 8 | 5 | 7 | single | ||
Ocamlbuild plugin to compile to JavaScript |
5.0 |
1 | 6 | 1 | 3 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 8 | 21 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 3 | 3 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 1 | 11 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 9 | 1 | 3 | single | ||
OCaml non-blocking streaming codec to decode and encode the JSON data format |
1.0.2 |
1 | 8 | 8 | 73 | single | ||
Implementation of JSON Web Signature/Token (RFC 7515) |
0.0.2 |
1 | 13 | 1 | 4 | single | ||
OCaml bindings for Kafka |
0.5 |
1 | 7 | 1 | 1 | single broken | ||
OCaml bindings for Kafka, Lwt bindings |
0.5 |
1 | 8 | 0 | 0 | single broken | ||
STM based on lock-free MCAS |
0.7.0 |
1 | 9 | 1 | 2 | single | ||
Key Derivation Functions: HKDF RFC 5869, PBKDF RFC 2898, SCRYPT RFC 7914 |
1.1.2 |
1 | 9 | 2 | 68 | single | ||
Fast implementation of queue in OCaml |
0.6 |
1 | 8 | 11 | 32 | single | ||
OpenGL bindings for ocaml |
1.07 |
2 | 7 | 0 | 0 | maintained | ||
OCaml interface to GTK |
2.18.13 → 3.1.5-1 |
2 | 7 | 4 | 4 | maintained outdated | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 4 | 13 | single outdated | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 0 | 0 | single outdated | ||
OCaml interface to Gnome rsvg2 library |
3.1.5 |
1 | 9 | 0 | 0 | single | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 2 | 9 | single outdated | ||
OCaml interface to Tcl/Tk, including OCaml library explorer OCamlBrowser |
1 | 7 | 0 | 0 | single broken | |||
OCaml bindings for BLAS and LAPACK |
11.1.1 |
1 | 8 | 1 | 1 | single | ||
Functional HTML scraping and rewriting with CSS in OCaml |
1.1.1 |
1 | 8 | 6 | 15 | single | ||
OCaml bindings to linenoise |
1.5.1 |
1 | 6 | 4 | 5 | single | ||
OCaml bindings distributed with LLVM |
21.1.8 |
1 | 8 | 0 | 0 | single | ||
Logs reporter to syslog (UDP/TCP/TLS) |
0.5.0 |
1 | 8 | 1 | 6 | single | ||
Scalable LRU caches for OCaml |
0.3.1 |
1 | 7 | 9 | 56 | single | ||
Embeddable Lua 2.5 interpreter implemented in OCaml |
0.9.5 |
1 | 6 | 1 | 1 | single | ||
Cooperative threads library for OCaml |
6.1.2 |
1 | 9 | 137 | 410 | single | ||
Lwt logging library (deprecated) |
1.1.2 |
1 | 6 | 1 | 1 | single broken | ||
Ppx syntax extension for Lwt |
6.1.2 |
1 | 7 | 14 | 31 | single | ||
Helpers for using React with Lwt |
1.2.0 |
1 | 8 | 5 | 15 | single | ||
OpenSSL binding with concurrent I/O |
1.2.0 |
1 | 7 | 6 | 33 | single | ||
Convert file extensions to MIME types |
1.3.1 |
1 | 5 | 8 | 40 | single | ||
Markdown parser and printer |
0.2.1 |
1 | 8 | 1 | 1 | single | ||
Cross-platform memory usage information |
0.2.0 |
1 | 5 | 0 | 0 | single | ||
LR(1) parser generator for OCaml |
20260203 → 20260209 |
1 | 8 | 67 | 938 | single outdated | ||
Runtime support library for GLR parsers generated by Menhir |
20260203 → 20260209 |
1 | 5 | 1 | 939 | single outdated | ||
Runtime support library for parsers generated by Menhir |
20260203 → 20260209 |
1 | 5 | 47 | 940 | single outdated | ||
Compile-time library for auxiliary tools related to Menhir |
20260203 → 20260209 |
1 | 5 | 20 | 940 | single outdated | ||
Editor-independent tool to ease the development of programs in OCaml |
5.8-505 |
2 | 12 | 0 | 0 | maintained | ||
Merlin’s libraries |
5.8-505 |
2 | 6 | 4 | 4 | maintained | ||
Metrics infrastructure for OCaml |
0.5.0 |
1 | 7 | 9 | 46 | single | ||
Influx reporter for the Metrics library |
0.5.0 |
1 | 9 | 0 | 0 | single | ||
Lwt backend for the Metrics library |
0.5.0 |
1 | 8 | 1 | 9 | single | ||
Resource usage (getrusage) sources for the Metrics library |
0.5.0 |
1 | 8 | 0 | 0 | single | ||
Unix backend for the Metrics library |
0.5.0 |
1 | 11 | 1 | 8 | single | ||
Modal Editing Witch |
0.1.0 |
1 | 7 | 1 | 8 | single | ||
Modal Editing Witch, VI interpreter |
0.5.0 |
1 | 7 | 1 | 7 | single | ||
Block signatures and implementations for MirageOS |
3.0.2 |
1 | 8 | 3 | 3 | single | ||
Block signatures and implementations for MirageOS using Lwt |
3.0.2 |
1 | 7 | 0 | 0 | single | ||
Libraries and module types for portable clocks |
4.2.0 |
1 | 5 | 7 | 14 | single | ||
Paravirtual implementation of the MirageOS Clock interface |
4.2.0 |
1 | 6 | 0 | 0 | single | ||
Unix-based implementation for the MirageOS Clock interface |
4.2.0 |
1 | 7 | 3 | 4 | single | ||
Implementations of Mirage console devices |
5.1.0 |
1 | 7 | 0 | 0 | single | ||
Abstract devices for MirageOS |
2.0.0 |
1 | 7 | 1 | 32 | single | ||
Flow implementations and combinators for MirageOS |
5.0.0 |
1 | 8 | 14 | 34 | single | ||
Flow implementations and combinators for MirageOS specialized to lwt |
5.0.0 |
1 | 10 | 2 | 4 | single | ||
Flow implementations and combinators for MirageOS on Unix |
5.0.0 |
1 | 12 | 0 | 0 | single | ||
MirageOS signatures for key/value devices |
6.1.1 |
1 | 10 | 2 | 20 | single | ||
Mirage reporter for the Logs library |
3.0.0 |
6 | 11 | 0 | 0 | maintained | ||
Monotonic time for MirageOS |
5.2.0 |
1 | 6 | 11 | 31 | single | ||
Network signatures for MirageOS |
4.0.0 |
1 | 10 | 5 | 31 | single | ||
Collect runtime profiling information in CTF format |
0.9.1 |
1 | 9 | 3 | 4 | single | ||
MirageOS signatures for network protocols |
8.0.0 |
1 | 9 | 0 | 0 | single | ||
POSIX clock for MirageOS |
5.2.0 |
1 | 6 | 10 | 24 | single | ||
Random signatures for MirageOS |
3.0.0 |
1 | 6 | 1 | 1 | single |