master · x86_64-linux · e7fccb1ad3ed · generated 2026-10-17T01:00:33Z
102,550packages 37,779unmaintained (36.8%) 41,932single maintainer (40.9%) 9,663team only (9.4%) 8,445broken 11,466outdated (11.2%) 4,941maintainers 85teams 207setup hooks (hidden)
Reset

37,779 packages · page 279 of 378

Package ▲ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Module to handle nested dictionaries
1.2.4
0
17 0 0 unmaintained
Collection of persistent (disk-based) queues for Python
1.10.0
0
17 1 3 unmaintained
Open-source software for simulating the dynamics of closed and open quantum systems
5.3.1
0
28 0 0 unmaintained
Module to generate SVG railroad syntax diagrams
3.0.1
0
16 0 0 unmaintained
Python RAML parser
0.2.2
0
26 0 0 unmaintained
Python 3 compatible Python 2 `random` Module
1.0.1 → 1.0.2
0
14 1 1 unmaintained outdated
RAR archive reader for Python
4.5
0
17 7 14 unmaintained
Legacy Python client for Sentry (getsentry.com) — replaced by sentry-python
6.10.0
0
13 0 0 unmaintained
CTypes based LibRaw bindings for Python
0.6.0
0
16 0 0 unmaintained
RBTools is a set of command line tools for working with Review Board and RBCommons
5.2.1 → 7.0
0
34 0 0 unmaintained outdated
CSS minifier written in pure python
1.2.2 → 1.3.0
0
13 1 2 unmaintained outdated
Parse Redis dump.rdb files, Analyze Memory, and Export Data to JSON
0.1.15
0
19 0 0 unmaintained
Python library for working with RDF
7.6.0
0
23 16 39 unmaintained
Show where your regex match assertion failed
1.1.0
0
18 1 3,403 unmaintained
Read mdx/mdd files (repacking of readmdict from mdict-analysis)
0.1.1
0
19 0 0 unmaintained
Readme is a library for rendering readme descriptions for Warehouse
0.7.1
0
14 0 0 unmaintained
Advanced string matching from simple patterns
6.0.1
0
18 2 5 unmaintained
This library helps you quickly implement an interactive command-based application
2025.12 → 2026.5
0
19 0 0 unmaintained outdated
Docutils-compatibility bridge to CommonMark
0.7.1
0
16 3 3 unmaintained
Library to link records in or between data sources
0.16
0
29 0 0 unmaintained
Enable recursive processing of pth files anywhere in sys.path
1.0
0
3 0 0 unmaintained
Simple manipulation and display of spatial regions
1.1.2
0
17 0 0 unmaintained
GPGPU algorithms for PyCUDA and PyOpenCL
0.9.0
0
17 0 0 unmaintained
Convert between TOML, YAML and JSON
2.1.4
0
26 0 0 unmaintained
Fast (basic) object serialization similar to bencode
1.0.8 → 1.0.9
0
19 1 2 unmaintained outdated
Unittest-compatible framework for repeating a test function over many fixtures
2.3.3
0
17 3 5 unmaintained
Open Source Python library for generating PDFs and graphics
5.0.1
0
18 17 27 unmaintained
Tiny LRU cache implementation and decorator
0.8
0
18 4 24 unmaintained
Auto-generate Sphinx API docs from Zope interfaces
1.1.0
0
20 0 0 unmaintained broken
WSGI Authentication Middleware / API
3.1.0 → 3.2.0
0
19 0 0 unmaintained outdated
Python library for ReqIF format
0.0.54 → 0.1.0
0
21 0 0 unmaintained outdated
Download files using requests and save them to a target path
0.1.2
0
17 0 0 unmaintained
Transport adapter for fetching file:// URLs with the requests python library
2.1.0 → 3.0.1
0
19 2 30 unmaintained outdated
Requests authentication module for HTTP Signature
0.7.1
0
18 0 0 unmaintained
Authentication handler for using Kerberos with Python Requests
0.15.0
0
20 5 44 unmaintained
Mock out responses from the requests package
1.12.1
0
23 132 1,634 unmaintained
HTTP NTLM authentication support for python-requests
1.3.0
0
19 4 6 unmaintained
Module for rate-limiting for requests
0.10.0
0
21 2 9 unmaintained
Use requests to talk HTTP via a UNIX domain socket
0.4.1 → 1.0.1
0
20 2 30 unmaintained outdated
Pip requirements file parser
0.13.1
0
18 4 4 unmaintained
Efficient signal resampling
0.4.3
0
21 3 37 unmaintained
Resolve abstract dependencies into concrete ones
1.2.1
0
18 3 13 unmaintained
reStructuredText linter
2.0.2
0
18 3 6 unmaintained
Rust-like result type for Python
0.17.0
0
19 1 2 unmaintained
High level wrapper of resvg for python
0.5.0
0
19 0 0 unmaintained
Python driver library for the RethinkDB database server
2.4.10.post1
0
18 0 0 unmaintained
Easy to use retry decorator
0.9.2 → 0.9.5
0
18 2 3 unmaintained outdated
Decorator for retrying when exceptions occur
1.1.1
0
14 0 0 unmaintained
General-purpose retrying library
1.4.2
0
17 4 10 unmaintained
RFC 3339 validator for Python
0.1.4
0
17 6 694 unmaintained
Validating URI References per RFC 3986
2.0.0
0
15 5 385 unmaintained
Pure python rfc3986 validator
0.1.1
0
16 2 140 unmaintained
Helper functions to syntactically validate strings according to RFC 3987
1.1.0
0
18 2 140 unmaintained
Python implementation of the Happy Eyeballs Algorithm
0.1.0
0
14 0 0 unmaintained
Swiss Army knife of sub-GHz ISM band radio
3.0.0
0
22 0 0 unmaintained
Rich-compatible library for writing pixel images and ASCII art to the terminal
3.0.1
0
21 0 0 unmaintained
Beautiful reStructuredText renderer for rich
2.1.0 → 2.2.0
0
19 1 14 unmaintained outdated
Rich toolkit for building command-line applications
0.20.1 → 0.20.6
0
22 2 574 unmaintained outdated
Python client library for RIPE ATLAS API
2.0.0
0
23 0 0 unmaintained
Parsing library for RIPE Atlas measurements results
1.3.1
0
17 0 0 unmaintained
Lean Persistent Homology Library for Python
0.6.15
0
23 1 1 unmaintained
RISC-V Architectural Test Framework
1.25.3
0
16 0 0 unmaintained
RISC-V configuration validator
3.18.3
0
20 1 1 unmaintained
ISA coverage extraction tool
0.18.0
0
22 1 1 unmaintained
Module to minify Javascript
1.2.5 → 1.3.0
0
13 1 2 unmaintained outdated
RLP serialization library
4.1.0 → 5.0.0
0
20 5 8 unmaintained outdated
Library for detecting if a HTTP User Agent header is likely to be a bot
0.4
0
14 0 0 unmaintained
Robot Framework keyword library wrapper around the HTTP client library requests
0.9.7
0
17 0 0 unmaintained
Web testing library for Robot Framework
3.0.0
0
14 0 0 unmaintained
SSHLibrary is a Robot Framework test library for SSH and SFTP
3.8.0
0
16 0 0 unmaintained
Tool for checking that Robot Framework test cases have expected statuses and log messages
4.1.1
0
17 1 2 unmaintained
Python unittest test suite for Robot Framework
3.0.1
0
17 0 0 unmaintained
Modern, multi-threaded and extensible web server
1.2.5
0
13 0 0 unmaintained
Screw remotes. Control your Roku with Python
4.1
0
16 0 0 unmaintained
Error tracking and logging from Python to Rollbar
1.4.0
0
18 0 0 unmaintained
Manipulate roman numerals
4.1.0
0
17 2 6,117 unmaintained
Python program and library to control Wi-Fi enabled iRobot Roombas
1.9.1 → 2.0.2
0
22 0 0 unmaintained outdated
Python refactoring library
1.15.0
0
20 4 11 unmaintained
Re-implementation of the Rails routes system for mapping URLs to application actions
2.5.1
0
17 0 0 unmaintained
PDB wrapper with remote access via TCP socket
0.2.0
0
16 0 0 unmaintained
RPM package manager
4.20.1 → 6.1.0
0
25 4 4 unmaintained outdated
Read rpm archive files
2.2.1
0
17 1 1 unmaintained
Lightweight way of building RPMs, and sabotaging them
0.5.7.1 → 0.6.7
0
14 0 0 unmaintained outdated
Pure-Python RSA implementation
4.9 → 4.9.1
0
18 10 658 unmaintained outdated
Convert reStructured Text to PDF via ReportLab
0.105
0
29 1 1 unmaintained
Encoder for unicode to RTF 1.5 command sequences
2.3
0
17 0 0 unmaintained
Python wrapper for RtMidi
0.2.2
0
15 0 0 unmaintained
Python object API for managing the Linux LIO kernel target
2.2.4
0
18 0 0 unmaintained
Common routines for ruamel packages
1.0.0
0
13 2 3,523 unmaintained
YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order
0.19.1
0
18 76 3,522 unmaintained
YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order
0.2.15
0
17 3 3,523 unmaintained
Run a block of text as a subprocess
1.2.2 → 1.3.0
0
19 1 25 unmaintained outdated
High performance Python graph library implemented in Rust
0.17.1 → 0.18.1
0
24 2 6 unmaintained outdated
Python library for communicate with Yamaha RX-Vxxx receivers
0.7.0
0
24 0 0 unmaintained
StarCraft II - client protocol
3.19.1.58600.0 → 5.0.17.98310.0
0
14 0 0 unmaintained outdated
C implementations of functions for use within SABnzbd
9.7.0
0
16 0 0 unmaintained
yEnc Decoding for Python 3
5.4.4 → 9.7.2
0
13 0 0 unmaintained outdated
Simple ANSI E1.31 (aka sACN) module
1.11.0
0
13 0 0 unmaintained
Safely make I/O operations to files in Python even from multiple threads
1.2
0
13 1 1 unmaintained
Library for training and deploying machine learning models on Amazon SageMaker
2.256.1 → 3.25.0
0
43 0 0 unmaintained outdated