master · x86_64-linux · e7fccb1ad3ed · generated 2026-10-17T01:00:33Z
102,550packages 37,779unmaintained (36.8%) 41,932single maintainer (40.9%) 9,663team only (9.4%) 8,445broken 11,466outdated (11.2%) 4,941maintainers 85teams 207setup hooks (hidden)
Reset

37,779 packages · page 305 of 378

Package ▲ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Python driver library for the RethinkDB database server
2.4.10.post1
0
18 1 1 unmaintained
Easy to use retry decorator
0.9.2 → 0.9.5
0
18 2 3 unmaintained outdated
Decorator for retrying when exceptions occur
1.1.1
0
14 0 0 unmaintained
General-purpose retrying library
1.4.2
0
17 7 17 unmaintained
RFC 3339 validator for Python
0.1.4
0
17 9 1,927 unmaintained
Validating URI References per RFC 3986
2.0.0
0
15 6 411 unmaintained
Pure python rfc3986 validator
0.1.1
0
16 4 118 unmaintained
Helper functions to syntactically validate strings according to RFC 3987
1.1.0
0
18 4 118 unmaintained
Python implementation of the Happy Eyeballs Algorithm
0.1.0
0
14 1 1 unmaintained
Swiss Army knife of sub-GHz ISM band radio
3.0.0
0
22 0 0 unmaintained
Rich-compatible library for writing pixel images and ASCII art to the terminal
3.0.1
0
21 2 2 unmaintained
Beautiful reStructuredText renderer for rich
2.1.0 → 2.2.0
0
19 2 26 unmaintained outdated
Rich toolkit for building command-line applications
0.20.1 → 0.20.6
0
22 3 793 unmaintained outdated
Python client library for RIPE ATLAS API
2.0.0
0
23 1 1 unmaintained
Parsing library for RIPE Atlas measurements results
1.3.1
0
17 1 1 unmaintained
Lean Persistent Homology Library for Python
0.6.15
0
23 1 1 unmaintained
RISC-V Architectural Test Framework
1.25.3
0
16 0 0 unmaintained
RISC-V configuration validator
3.18.3
0
20 1 1 unmaintained
ISA coverage extraction tool
0.18.0
0
22 1 1 unmaintained
Module to minify Javascript
1.2.5 → 1.3.0
0
13 4 7 unmaintained outdated
RLP serialization library
4.1.0 → 5.0.0
0
20 5 12 unmaintained outdated
Library for detecting if a HTTP User Agent header is likely to be a bot
0.4
0
14 1 2 unmaintained
Robot Framework keyword library wrapper around the HTTP client library requests
0.9.7
0
17 0 0 unmaintained
Web testing library for Robot Framework
3.0.0
0
14 0 0 unmaintained
SSHLibrary is a Robot Framework test library for SSH and SFTP
3.8.0
0
16 0 0 unmaintained
Tool for checking that Robot Framework test cases have expected statuses and log messages
4.1.1
0
17 1 2 unmaintained
Python unittest test suite for Robot Framework
3.0.1
0
17 0 0 unmaintained
Modern, multi-threaded and extensible web server
1.2.5
0
13 0 0 unmaintained
Screw remotes. Control your Roku with Python
4.1
0
16 0 0 unmaintained
Error tracking and logging from Python to Rollbar
1.4.0
0
18 2 2 unmaintained
Manipulate roman numerals
4.1.0
0
17 3 41,332 unmaintained
Python program and library to control Wi-Fi enabled iRobot Roombas
1.9.1 → 2.0.2
0
22 1 1 unmaintained outdated
Python refactoring library
1.15.0
0
20 6 13 unmaintained
Re-implementation of the Rails routes system for mapping URLs to application actions
2.5.1
0
17 0 0 unmaintained
PDB wrapper with remote access via TCP socket
0.2.0
0
16 0 0 unmaintained
Read rpm archive files
2.2.1
0
17 3 4 unmaintained
Lightweight way of building RPMs, and sabotaging them
0.5.7.1 → 0.6.7
0
14 0 0 unmaintained outdated
Pure-Python RSA implementation
4.9 → 4.9.1
0
18 21 781 unmaintained outdated
Convert reStructured Text to PDF via ReportLab
0.105
0
29 1 1 unmaintained
Encoder for unicode to RTF 1.5 command sequences
2.3
0
17 0 0 unmaintained
Python wrapper for RtMidi
0.2.2
0
15 0 0 unmaintained
Python object API for managing the Linux LIO kernel target
2.2.4
0
18 1 1 unmaintained
Common routines for ruamel packages
1.0.0
0
13 4 6,164 unmaintained
YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order
0.19.1
0
18 139 6,163 unmaintained
YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order
0.2.15
0
17 7 6,164 unmaintained
Run a block of text as a subprocess
1.2.2 → 1.3.0
0
19 1 30 unmaintained outdated
High performance Python graph library implemented in Rust
0.17.1 → 0.18.1
0
24 5 9 unmaintained outdated
Python library for communicate with Yamaha RX-Vxxx receivers
0.7.0
0
24 1 1 unmaintained
StarCraft II - client protocol
3.19.1.58600.0 → 5.0.17.98310.0
0
14 0 0 unmaintained outdated
C implementations of functions for use within SABnzbd
9.7.0
0
16 0 0 unmaintained
yEnc Decoding for Python 3
5.4.4 → 9.7.2
0
13 0 0 unmaintained outdated
Simple ANSI E1.31 (aka sACN) module
1.11.0
0
13 1 1 unmaintained
Safely make I/O operations to files in Python even from multiple threads
1.2
0
13 2 2 unmaintained
Library for training and deploying machine learning models on Amazon SageMaker
2.256.1 → 3.25.0
0
43 0 0 unmaintained outdated
PyYaml wrapper with sane behaviour to read and write readable YAML safely
0.6.1
0
18 3 16 unmaintained
Simple Authentication for Sanic
0.3.0
0
19 0 0 unmaintained
Core routing component for the Sanic web framework
23.12.0
0
15 1 25 unmaintained
Core testing clients for the Sanic web framework
24.6.0
0
19 8 15 unmaintained
Python wrapper for subprocess which provides command pipeline functionality
0.1.7.post1 → 0.1.8
0
14 1 1 unmaintained outdated
Classes implementing the SARIF 2.1.0 object model
1.0.4
0
15 1 503 unmaintained
Create a dependency graph of the components within a SBOM
0.3.2
0
17 0 0 unmaintained
SBOM generator for files within a directory
0.4.5
0
18 0 0 unmaintained
Python job scheduling for humans
1.2.2
0
13 1 2 unmaintained
Python extension module which implements the fast marching method
2025.6.23
0
17 2 2 unmaintained
Multiple Pairwise Comparisons (Post Hoc) Tests in Python
0.17.1
0
23 0 0 unmaintained
Survival analysis built on top of scikit-learn
0.28.0
0
30 0 0 unmaintained
Topological Data Analysis for humans
1.1.1
0
25 0 0 unmaintained
Implementation of the SCRAM authentication protocol
1.4.5 → 1.4.17
0
20 2 614 unmaintained outdated
Library for testing interactive command-line applications
3.0
0
18 2 2 unmaintained
Python library to access Ocean Optics spectrometers
2.11.0
0
27 0 0 unmaintained
Robustly estimate trend and periodicity in a timeseries
0.3.1
0
21 0 0 unmaintained
Python FFI bindings for secp256k1
0.14.0
0
16 1 3 unmaintained
Adds optional security headers and cookie attributes for Python web frameworks
1.0.1 → 2.0.1
0
19 0 0 unmaintained outdated
Unicode Standard tokenization routines and orthography profile segmentation
2.4.0
0
21 2 20 unmaintained
Fast Python library for SEGY files
1.9.14
0
15 0 0 unmaintained
Send file to trash natively under macOS, Windows and Linux
2.1.0
0
17 11 123 unmaintained
Text to sentence splitter using heuristic algorithm by Philipp Koehn and Josh Schroeder
1.4
0
15 0 0 unmaintained
Multilingual Sentence & Image Embeddings with BERT
6.1.0
0
37 10 14 unmaintained
Create sentinel and singleton objects
1.0.0
0
13 0 0 unmaintained
SEPA Direct Debit XML generation in python
2.7.0
0
17 2 5 unmaintained
Python framework for sequence labeling evaluation
1.2.2
0
16 0 0 unmaintained
Ridiculously fast object serialization
0.3.1
0
14 0 0 unmaintained
Utility that accesses files on a HTTP server and stores them locally for reuse
0.3.1
0
15 0 0 unmaintained
Setuptools revision control system plugin for Git
1.2
0
16 3 3 unmaintained
Use git repo data (latest tag, current commit hash, etc) for building a version number according PEP-440
3.1.0 → 3.2.0
0
27 7 16 unmaintained outdated
Setuptools plugin for Rust support
1.13.0
0
18 36 7,870 unmaintained
setuptools_scm plugin for git archives
1.4.1
0
18 0 0 unmaintained broken
S-expression parser for Python
1.0.2
0
16 7 7 unmaintained
Free asynchronous library from reverse engineered Shazam API
0.8.1
0
26 1 1 unmaintained broken
Generator for the PySide2 Qt bindings
5.15.17 → 5.15.19
0
9 2 2 unmaintained broken outdated
Generator for the pyside6 Qt bindings - Python library
6.12.0
0
7 17 508 unmaintained
Generator for the pyside6 Qt bindings - tools
6.12.0
0
8 15 509 unmaintained
Open the system file manager and select files in it
1.1.6
0
19 2 2 unmaintained
Client-side Sieve and Managesieve library
1.6.0
0
19 0 0 unmaintained
Sign JSON with Ed25519 signatures
1.1.4
0
21 2 7 unmaintained
Utilities for working with inspect.Signature objects
4.0.1
0
21 4 6 unmaintained
Simple S-expression parser
0.3.1
0
17 1 1 unmaintained
Very simple Salesforce.com REST API client for Python
1.12.10
0
27 0 0 unmaintained
Memory-based naive bayesian text classifier
1.5.8 → 3.2.0
0
15 0 0 unmaintained outdated
Simple FIX Protocol implementation for Python
1.0.17
0
14 0 0 unmaintained