vbgl Vincent Laporte
github.com/vbgl · maintains 464 packages (463 directly), sole maintainer of 388, member of 0 teams
464 packages · page 3 of 5
| Package ▼ | Version | Maintainers | # | Teams | Deps | Used by | Used by (transitive) | Status |
|---|---|---|---|---|---|---|---|---|
Ppx syntax extension for Lwt |
6.1.2 |
1 | 7 | 14 | 31 | single | ||
Lwt logging library (deprecated) |
1.1.2 |
1 | 6 | 1 | 1 | single broken | ||
Cooperative threads library for OCaml |
6.1.2 |
1 | 9 | 137 | 410 | single | ||
Embeddable Lua 2.5 interpreter implemented in OCaml |
0.9.5 |
1 | 6 | 1 | 1 | single | ||
Scalable LRU caches for OCaml |
0.3.1 |
1 | 7 | 9 | 56 | single | ||
Logs reporter to syslog (UDP/TCP/TLS) |
0.5.0 |
1 | 8 | 1 | 6 | single | ||
OCaml bindings distributed with LLVM |
21.1.8 |
1 | 8 | 0 | 0 | single | ||
OCaml bindings to linenoise |
1.5.1 |
1 | 6 | 4 | 5 | single | ||
Functional HTML scraping and rewriting with CSS in OCaml |
1.1.1 |
1 | 8 | 6 | 15 | single | ||
OCaml bindings for BLAS and LAPACK |
11.1.1 |
1 | 8 | 1 | 1 | single | ||
OCaml interface to Tcl/Tk, including OCaml library explorer OCamlBrowser |
1 | 7 | 0 | 0 | single broken | |||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 2 | 9 | single outdated | ||
OCaml interface to Gnome rsvg2 library |
3.1.5 |
1 | 9 | 0 | 0 | single | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 0 | 0 | single outdated | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 4 | 13 | single outdated | ||
OCaml interface to GTK |
2.18.13 → 3.1.5-1 |
2 | 7 | 4 | 4 | maintained outdated | ||
OpenGL bindings for ocaml |
1.07 |
2 | 7 | 0 | 0 | maintained | ||
Fast implementation of queue in OCaml |
0.6 |
1 | 8 | 11 | 32 | single | ||
Key Derivation Functions: HKDF RFC 5869, PBKDF RFC 2898, SCRYPT RFC 7914 |
1.1.2 |
1 | 9 | 2 | 68 | single | ||
STM based on lock-free MCAS |
0.7.0 |
1 | 9 | 1 | 2 | single | ||
OCaml bindings for Kafka, Lwt bindings |
0.5 |
1 | 8 | 0 | 0 | single broken | ||
OCaml bindings for Kafka |
0.5 |
1 | 7 | 1 | 1 | single broken | ||
Implementation of JSON Web Signature/Token (RFC 7515) |
0.0.2 |
1 | 13 | 1 | 4 | single | ||
OCaml non-blocking streaming codec to decode and encode the JSON data format |
1.0.2 |
1 | 8 | 8 | 73 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 9 | 1 | 3 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 1 | 11 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 3 | 3 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 8 | 21 | single | ||
Ocamlbuild plugin to compile to JavaScript |
5.0 |
1 | 6 | 1 | 3 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 8 | 5 | 7 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 11 | 7 | 312 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 14 | 39 | single | ||
Library that parses Java .class files into OCaml data structures |
3.2.2 |
1 | 7 | 1 | 2 | single | ||
ISO 8601 and RFC 3999 date parsing for OCaml |
0.2.5 |
1 | 5 | 5 | 10 | single | ||
Portable Irmin watch backends using FSevents or Inotify |
0.5.0 |
1 | 9 | 3 | 5 | single | ||
Irmin test suite |
3.11.0 |
2 | 21 | 5 | 7 | maintained | ||
Irmin backend which stores values in a pack file |
3.11.0 |
2 | 20 | 1 | 1 | maintained | ||
MirageOS-compatible Irmin stores |
3.11.0 |
2 | 12 | 0 | 0 | maintained | ||
MirageOS-compatible Irmin stores |
3.11.0 |
2 | 17 | 0 | 0 | maintained | ||
MirageOS-compatible Irmin stores |
3.11.0 |
2 | 9 | 2 | 2 | maintained | ||
GraphQL server for Irmin |
3.11.0 |
2 | 16 | 1 | 1 | maintained | ||
Git backend for Irmin |
3.11.0 |
2 | 24 | 1 | 1 | maintained | ||
Generic file-system backend for Irmin |
3.11.0 |
2 | 12 | 1 | 1 | maintained | ||
Mergeable Irmin data structures |
3.11.0 |
2 | 13 | 0 | 0 | maintained | ||
Irmin backend which allow to store values into chunks |
3.11.0 |
2 | 11 | 0 | 0 | maintained | ||
Distributed database built on the same principles as Git |
3.11.0 |
2 | 23 | 9 | 11 | maintained | ||
IRI (RFC3987) native OCaml implementation |
1.2.0 |
1 | 8 | 1 | 6 | single | ||
IO memory page library for Mirage backends |
3.0.0 |
1 | 9 | 5 | 8 | single | ||
Various signed and unsigned integer types for OCaml |
0.8.0 |
1 | 6 | 7 | 73 | single | ||
Bindings for Linux’s filesystem monitoring interface, inotify |
2.6 |
1 | 8 | 1 | 2 | single | ||
Platform-agnostic multi-level index |
1.6.2 |
1 | 19 | 1 | 2 | single | ||
Image formats such as PNG and PPM in OCaml |
20221222 |
1 | 8 | 0 | 0 | single | ||
Lwt support for httpun-ws |
0.2.0 |
1 | 9 | 0 | 0 | single | ||
Websocket implementation for httpun |
0.2.0 |
1 | 12 | 4 | 7 | single | ||
Common HTTP/1.x types |
0.2.0 |
1 | 6 | 3 | 30 | single | ||
Lwt + Unix support for httpun |
0.2.0 |
1 | 7 | 1 | 4 | single | ||
Lwt support for httpun |
0.2.0 |
1 | 9 | 1 | 5 | single | ||
EIO support for httpun |
0.2.0 |
1 | 7 | 1 | 1 | single | ||
High-performance, memory-efficient, and scalable HTTP library for OCaml |
0.2.0 |
1 | 10 | 3 | 11 | single | ||
Lwt support for http/af |
0.7.1 |
1 | 8 | 1 | 1 | single | ||
High-performance, memory-efficient, and scalable web server for OCaml |
0.7.1 |
1 | 9 | 4 | 4 | single | ||
HTTP client for MirageOS |
0.0.11 |
1 | 13 | 1 | 1 | single | ||
CoHTTP implementation using the Lwt concurrency library |
6.3.0 |
1 | 5 | 3 | 37 | single | ||
Minimal OCaml library providing hexadecimal converters |
1.5.0 |
1 | 6 | 14 | 74 | single | ||
Connecting to a remote host via IP version 4 or 6 using Mirage |
2.0.2 |
2 | 15 | 3 | 14 | maintained | ||
Connecting to a remote host via IP version 4 or 6 using Miou |
2.0.2 |
2 | 14 | 2 | 2 | maintained | ||
Connecting to a remote host via IP version 4 or 6 using Lwt_unix |
2.0.2 |
2 | 15 | 2 | 8 | maintained | ||
Connecting to a remote host via IP version 4 or 6 |
2.0.2 |
2 | 10 | 7 | 21 | maintained | ||
High-performance, memory-efficient, and scalable web server for OCaml |
1.1.1 |
1 | 11 | 5 | 13 | single | ||
OCaml bindings to the GNU Scientific Library |
1.25.1 |
1 | 8 | 2 | 2 | single | ||
Library for parsing GraphQL queries |
0.14.0 |
1 | 9 | 1 | 9 | single | ||
Build GraphQL schemas with Lwt support |
0.14.0 |
1 | 8 | 3 | 7 | single | ||
Run GraphQL servers with “cohttp” |
0.14.0 |
1 | 14 | 1 | 2 | single | ||
Build GraphQL schemas and execute queries against them |
0.14.0 |
1 | 9 | 2 | 8 | single | ||
Heterogenous maps over a GADT |
0.3.0 |
1 | 7 | 2 | 75 | single | ||
Unix backend for the Git protocol(s) |
3.18.0 |
2 | 35 | 3 | 5 | maintained | ||
Package to use HTTP-based ocaml-git with MirageOS backend |
3.18.0 |
2 | 21 | 2 | 7 | maintained | ||
Package to use ocaml-git with MirageOS backend |
3.18.0 |
2 | 30 | 1 | 6 | maintained | ||
Git format and protocol in pure OCaml |
3.18.0 |
2 | 37 | 6 | 8 | maintained | ||
Distributed computing library for Objective Caml which facilitates distributed execution of parallelizable computations in a seamless fashion |
0.6 |
1 | 4 | 1 | 1 | single broken | ||
Dune's file system IO library |
3.23.1 → 3.24.2 |
1 | 5 | 1 | 99 | single outdated | ||
OCaml module for handling file system paths with POSIX and Windows conventions |
0.7.3 |
1 | 8 | 36 | 269 | single | ||
Fontconfig bindings for OCaml |
unstable-2013-11-03 |
1 | 5 | 0 | 0 | single | ||
OCaml Format pretty-printer combinators |
0.11.0 |
1 | 8 | 126 | 835 | single | ||
Simple OCaml module for computing the least solution of a system of monotone equations |
20250919 |
1 | 5 | 17 | 40 | single | ||
OCaml API to manipulate real files (POSIX like) and filenames |
0.6.6 |
1 | 8 | 5 | 9 | single | ||
OCaml binding for the fdk-aac library |
0.3.3 |
2 | 7 | 0 | 0 | maintained | ||
Printf-like for Faraday library |
0.3 |
1 | 8 | 0 | 0 | single | ||
Lwt + Unix support for Faraday |
0.8.2 |
1 | 7 | 3 | 9 | single | ||
Lwt support for Faraday |
0.8.2 |
1 | 7 | 2 | 11 | single | ||
Async support for Faraday |
0.8.2 |
1 | 8 | 1 | 1 | single | ||
Serialization library built for speed and memory efficiency |
0.8.2 |
1 | 7 | 15 | 53 | single | ||
Easy interface on top of the Jsonm library |
1.3.0 |
1 | 8 | 10 | 22 | single | ||
XML Parser for discrete data |
0.3+20180112 |
1 | 5 | 1 | 1 | single broken | ||
Constant time equal function to avoid timing attacks in OCaml |
0.10 |
1 | 7 | 0 | 0 | single | ||
Constant time equal function to avoid timing attacks in OCaml |
0.10 |
1 | 5 | 6 | 120 | single | ||
Library to generate encoder/decoder which ensure isomorphism |
0.8.1 |
1 | 9 | 1 | 9 | single | ||
Embeddable λProlog Interpreter |
3.8.0 |
1 | 15 | 0 | 0 | single | ||
ETH LIbrary for Numerical Analysis |
1.1 → 1.3.2 |
1 | 10 | 0 | 0 | single outdated | ||
High-level and functional interface to the Format module of the OCaml standard library |
1.3.4 |
1 | 5 | 4 | 20 | single |