master · x86_64-linux · 004f0f906834 · generated 2026-10-14T00:47:15Z
102,325packages 37,777unmaintained (36.9%) 41,893single maintainer (40.9%) 9,537team only (9.3%) 8,403broken 12,327outdated (12.0%) 4,936maintainers 85teams 206setup hooks (hidden)
Reset

37,777 packages · page 100 of 378

Package ▼ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Re-implementation of the Rails routes system for mapping URLs to application actions
2.5.1
0
17 0 0 unmaintained
Python refactoring library
1.15.0
0
20 4 11 unmaintained
Python program and library to control Wi-Fi enabled iRobot Roombas
1.9.1 → 2.0.2
0
22 0 0 unmaintained outdated
Manipulate roman numerals
4.1.0
0
17 2 6,039 unmaintained
Error tracking and logging from Python to Rollbar
1.3.0 → 1.5.0
0
18 0 0 unmaintained outdated
Screw remotes. Control your Roku with Python
4.1
0
16 0 0 unmaintained
Modern, multi-threaded and extensible web server
1.2.5
0
13 0 0 unmaintained
Python unittest test suite for Robot Framework
3.0.1
0
17 0 0 unmaintained
Tool for checking that Robot Framework test cases have expected statuses and log messages
4.1.1
0
17 1 2 unmaintained
SSHLibrary is a Robot Framework test library for SSH and SFTP
3.8.0
0
16 0 0 unmaintained
Web testing library for Robot Framework
3.0.0
0
14 0 0 unmaintained
Robot Framework keyword library wrapper around the HTTP client library requests
0.9.7
0
17 0 0 unmaintained
Library for detecting if a HTTP User Agent header is likely to be a bot
0.4
0
14 0 0 unmaintained
RLP serialization library
4.1.0 → 5.0.0
0
20 5 8 unmaintained outdated
Module to minify Javascript
1.2.5 → 1.3.0
0
13 1 2 unmaintained outdated
ISA coverage extraction tool
0.18.0
0
22 1 1 unmaintained
RISC-V configuration validator
3.18.3
0
20 1 1 unmaintained
RISC-V Architectural Test Framework
1.25.3
0
16 0 0 unmaintained
Lean Persistent Homology Library for Python
0.6.15
0
23 1 1 unmaintained
Parsing library for RIPE Atlas measurements results
1.3.1
0
17 0 0 unmaintained
Python client library for RIPE ATLAS API
2.0.0
0
23 0 0 unmaintained
Rich toolkit for building command-line applications
0.20.1 → 0.20.6
0
22 2 567 unmaintained outdated
Beautiful reStructuredText renderer for rich
2.1.0 → 2.2.0
0
19 1 14 unmaintained outdated
Rich-compatible library for writing pixel images and ASCII art to the terminal
3.0.1
0
21 0 0 unmaintained
Swiss Army knife of sub-GHz ISM band radio
3.0.0
0
22 0 0 unmaintained
Python implementation of the Happy Eyeballs Algorithm
0.1.0
0
14 0 0 unmaintained
Helper functions to syntactically validate strings according to RFC 3987
1.1.0
0
18 2 139 unmaintained
Pure python rfc3986 validator
0.1.1
0
16 2 139 unmaintained
Validating URI References per RFC 3986
2.0.0
0
15 5 384 unmaintained
RFC 3339 validator for Python
0.1.4
0
17 6 693 unmaintained
General-purpose retrying library
1.4.2
0
17 4 10 unmaintained
Decorator for retrying when exceptions occur
1.1.1
0
14 0 0 unmaintained
Easy to use retry decorator
0.9.2 → 0.9.5
0
18 2 3 unmaintained outdated
Python driver library for the RethinkDB database server
2.4.10.post1
0
18 0 0 unmaintained
High level wrapper of resvg for python
0.5.0
0
19 0 0 unmaintained
Rust-like result type for Python
0.17.0
0
19 1 2 unmaintained
reStructuredText linter
2.0.2
0
18 3 6 unmaintained
Resolve abstract dependencies into concrete ones
1.2.1
0
18 3 13 unmaintained
Efficient signal resampling
0.4.3
0
21 3 37 unmaintained
Pip requirements file parser
0.13.1
0
18 4 4 unmaintained
Use requests to talk HTTP via a UNIX domain socket
0.4.1 → 1.0.1
0
20 2 30 unmaintained outdated
Module for rate-limiting for requests
0.10.0
0
21 2 9 unmaintained
HTTP NTLM authentication support for python-requests
1.3.0
0
19 4 6 unmaintained
Mock out responses from the requests package
1.12.1
0
23 132 1,620 unmaintained
Authentication handler for using Kerberos with Python Requests
0.15.0
0
20 5 44 unmaintained
Requests authentication module for HTTP Signature
0.7.1
0
18 0 0 unmaintained
Transport adapter for fetching file:// URLs with the requests python library
2.1.0 → 3.0.1
0
19 2 30 unmaintained outdated
Download files using requests and save them to a target path
0.1.2
0
17 0 0 unmaintained
Python library for ReqIF format
0.0.54 → 0.1.0
0
21 0 0 unmaintained outdated
WSGI Authentication Middleware / API
3.1.0 → 3.2.0
0
19 0 0 unmaintained outdated
Auto-generate Sphinx API docs from Zope interfaces
1.0.0 → 1.1.0
0
20 0 0 unmaintained broken outdated
Tiny LRU cache implementation and decorator
0.7 → 0.8
0
17 4 24 unmaintained outdated
Open Source Python library for generating PDFs and graphics
5.0.1
0
18 17 27 unmaintained
Unittest-compatible framework for repeating a test function over many fixtures
2.3.3
0
17 3 5 unmaintained
Fast (basic) object serialization similar to bencode
1.0.8 → 1.0.9
0
19 1 2 unmaintained outdated
Convert between TOML, YAML and JSON
2.1.4
0
26 0 0 unmaintained
GPGPU algorithms for PyCUDA and PyOpenCL
0.9.0
0
17 0 0 unmaintained
Simple manipulation and display of spatial regions
1.1.2
0
17 0 0 unmaintained
Enable recursive processing of pth files anywhere in sys.path
1.0
0
3 0 0 unmaintained
Library to link records in or between data sources
0.16
0
29 0 0 unmaintained
Docutils-compatibility bridge to CommonMark
0.7.1
0
16 3 3 unmaintained
This library helps you quickly implement an interactive command-based application
2025.12 → 2026.5
0
19 0 0 unmaintained outdated
Advanced string matching from simple patterns
6.0.1
0
18 2 5 unmaintained
Readme is a library for rendering readme descriptions for Warehouse
0.7.1
0
14 0 0 unmaintained
Read mdx/mdd files (repacking of readmdict from mdict-analysis)
0.1.1
0
19 0 0 unmaintained
Show where your regex match assertion failed
1.1.0
0
18 1 3,234 unmaintained
Python library for working with RDF
7.6.0
0
23 16 39 unmaintained
Parse Redis dump.rdb files, Analyze Memory, and Export Data to JSON
0.1.15
0
19 0 0 unmaintained
CSS minifier written in pure python
1.2.2 → 1.3.0
0
13 1 2 unmaintained outdated
RBTools is a set of command line tools for working with Review Board and RBCommons
5.2.1 → 7.0
0
34 0 0 unmaintained outdated
CTypes based LibRaw bindings for Python
0.6.0
0
16 0 0 unmaintained
Legacy Python client for Sentry (getsentry.com) — replaced by sentry-python
6.10.0
0
13 0 0 unmaintained
RAR archive reader for Python
4.5
0
17 7 14 unmaintained
Python 3 compatible Python 2 `random` Module
1.0.1 → 1.0.2
0
14 1 1 unmaintained outdated
Python RAML parser
0.2.2
0
26 0 0 unmaintained
Module to generate SVG railroad syntax diagrams
3.0.1
0
16 0 0 unmaintained
Open-source software for simulating the dynamics of closed and open quantum systems
5.3.1
0
28 0 0 unmaintained
Collection of persistent (disk-based) queues for Python
1.10.0
0
17 1 3 unmaintained
Module to handle nested dictionaries
1.2.4
0
17 0 0 unmaintained
Quantities is designed to handle arithmetic and conversions of physical quantities
0.16.4
0
19 2 2 unmaintained
Python Implementation of Graham Cormode and S. Muthukrishnan's Effective Computation of Biased Quantiles over Data Streams in ICDE'05
1.1
0
13 1 6 unmaintained
Abstraction layer for PyQt5/PyQt6/PySide2/PySide6
2.4.3
0
14 15 24 unmaintained
Iconic fonts in PyQt and PySide applications
1.4.1 → 1.4.2
0
15 1 1 unmaintained outdated
Qt stylesheet generation utility for PyQt/PySide
0.2.4
0
21 1 1 unmaintained
Python binding to QScintilla, Qt based text editing control
2.14.1
0
22 0 0 unmaintained
High-quality QR Code generator library in many languages
1.8.0
0
16 0 0 unmaintained
Software for developing quantum computing programs
0.7.0
0
26 1 1 unmaintained broken
Software for developing quantum computing programs
0.7.2 → 0.8.0
0
27 0 0 unmaintained broken outdated
Software for developing quantum computing programs
0.9.0 → 0.9.1
0
23 0 0 unmaintained broken outdated
Software for developing quantum computing programs
0.4.1
0
30 0 0 unmaintained broken
High performance simulators for Qiskit
0.17.2
0
27 3 3 unmaintained
Software for developing quantum computing programs
2.4.1 → 2.5.2
0
25 5 5 unmaintained outdated
Small python extension for quickly converting between QImages and numpy.ndarrays (in both directions)
1.10.0
0
15 1 1 unmaintained
Qiling Advanced Binary Emulation Framework
1.4.6
0
25 0 0 unmaintained broken
Python interface to the QDLDL
0.1.7.post5 → 0.1.9.post1
0
22 1 6 unmaintained outdated
Allows coroutines to be used in PyQt/PySide applications by providing an implementation of the PEP 3156 event-loop
0.28.0
0
18 0 0 unmaintained
Python bindings for ØMQ
27.1.0 → 27.2.0
0
26 25 960 unmaintained outdated
Extending PyYAML with a custom constructor for including YAML files within YAML files
2.2
0
21 1 131 unmaintained
Excel 2007-2010 Binary Workbook (xlsb) parser
1.0.10
0
13 1 1 unmaintained
Python 3 port of pyxl for writing structured and reusable inline HTML
1.4
0
14 0 0 unmaintained