41,932 packages · page 285 of 420
| Package ▼ | Version | Maintainers | # | Teams | Deps | Used by | Used by (transitive) | Status |
|---|---|---|---|---|---|---|---|---|
Access C-like structures directly from OCaml |
6.3.0 |
1 | 6 | 50 | 224 | single | ||
OCaml client for the various icecast & shoutcast source protocols |
1.0.3 |
1 | 5 | 0 | 0 | single | ||
Property fuzzing for OCaml |
0.2.2 |
1 | 13 | 19 | 167 | single | ||
Detect CPU features from OCaml |
0.1.2 |
1 | 5 | 0 | 0 | single | ||
Core pinning library |
2.0.0 |
1 | 6 | 1 | 1 | single | ||
Plugin to use cppo with ocamlbuild |
1.8.0 |
1 | 6 | 0 | 0 | single | ||
C preprocessor for OCaml |
1.8.0 |
1 | 5 | 32 | 505 | single | ||
Caml on the Web |
2.5.0 |
1 | 10 | 0 | 0 | single | ||
Cool implementation of normalization by evaluation (nbe) & elaboration for Cartesian cubical type theory |
unstable-2023-10-03 |
1 | 16 | 0 | 0 | single | ||
OCaml library used to manage the configuration file(s) of an application |
1.2 |
1 | 5 | 0 | 0 | single broken | ||
Network connection establishment library for MirageOS |
8.0.0 |
1 | 24 | 2 | 2 | single | ||
Network connection establishment library for Lwt_unix |
8.0.0 |
1 | 14 | 1 | 25 | single | ||
Network connection establishment library for Lwt |
8.0.0 |
1 | 9 | 4 | 28 | single | ||
Network connection establishment library for Async |
8.0.0 |
1 | 15 | 2 | 7 | single | ||
Network connection establishment library |
8.0.0 |
1 | 11 | 2 | 37 | single | ||
Identify type of your file (such as the MIME type) |
0.0.7 → 0.0.8 |
1 | 11 | 1 | 1 | single outdated | ||
Identify type of your file (such as the MIME type) |
0.0.7 → 0.0.8 |
1 | 12 | 0 | 0 | single outdated | ||
Database of decision trees to recognize MIME type |
0.0.7 → 0.0.8 |
1 | 10 | 1 | 1 | single outdated | ||
Identify type of your file (such as the MIME type) |
0.0.7 → 0.0.8 |
1 | 12 | 0 | 0 | single outdated | ||
Identify type of your file (such as the MIME type) |
0.0.7 → 0.0.8 |
1 | 12 | 3 | 4 | single outdated | ||
Converts between different color formats |
0.2.0 → 0.3.0 |
1 | 6 | 0 | 0 | single outdated | ||
SMTP protocol according to RFC5321 without extensions |
0.12.1 → 0.13.1 |
1 | 11 | 2 | 2 | single outdated | ||
HTTP(S) library for Lwt, Async and Mirage |
5.3.1 |
1 | 14 | 3 | 8 | single | ||
CoHTTP toplevel pretty printers for HTTP types |
6.3.0 |
1 | 7 | 0 | 0 | single | ||
Lightweight Cohttp + Lwt based HTTP server |
6.3.0 |
1 | 9 | 0 | 0 | single | ||
CoHTTP implementation using the Lwt concurrency library |
5.3.1 |
1 | 11 | 1 | 1 | single | ||
CoHTTP implementation for Unix and Windows using Lwt |
6.3.0 |
1 | 13 | 14 | 24 | single | ||
CoHTTP implementation for the Js_of_ocaml JavaScript compiler |
6.3.0 |
1 | 15 | 2 | 2 | single | ||
CoHTTP implementation using the Lwt concurrency library |
6.3.0 |
1 | 12 | 7 | 30 | single | ||
CoHTTP implementation with eio backend |
6.3.0 |
1 | 17 | 0 | 0 | single | ||
CoHTTP implementation for the Async concurrency library |
5.3.1 |
1 | 24 | 2 | 5 | single | ||
CoHTTP implementation for the Async concurrency library |
6.3.0 |
1 | 23 | 1 | 1 | single | ||
HTTP(S) library for Lwt, Async and Mirage |
6.3.0 |
1 | 16 | 15 | 36 | single | ||
OCaml module for the declarative definition of command line interfaces |
1.0.4 |
1 | 3 | 2 | 2 | single | ||
OCaml module for the declarative definition of command line interfaces |
1.3.0 |
1 | 3 | 16 | 28 | single | ||
Collection of cmdliner terms to control OCaml runtime parameters |
1.0.1 |
1 | 6 | 0 | 0 | single | ||
OCaml module for the declarative definition of command line interfaces |
2.1.1 |
1 | 3 | 94 | 881 | single | ||
Verifiable Delay Functions bindings to Chia's VDF |
0.0.5 |
1 | 13 | 0 | 0 | single | ||
Front-end for the C programming language that facilitates program analysis and transformation |
1.7.3 |
1 | 6 | 0 | 0 | single broken | ||
ADLER-32 and CRC32C Cyclic Redundancy Check |
0.5.4 |
1 | 13 | 4 | 20 | single | ||
Analyze Rust crates without touching compiler internals |
2026.08.15 |
1 | 11 | 1 | 1 | single | ||
Simple Core-inspired wrapper for standard library Stream module |
1.3.2 |
1 | 9 | 0 | 0 | single | ||
Implementation of the Concise Binary Object Representation (CBOR) as specified by RFC 8949 for OCaml |
0.1.0 |
1 | 10 | 1 | 2 | single | ||
CBOR encoder/decoder (RFC 7049) - native OCaml implementation |
0.5 |
1 | 7 | 1 | 1 | single | ||
CSS generation and manipulation library for OCaml |
1.1.0 → 1.2.1 |
1 | 13 | 1 | 1 | single outdated | ||
Implementation of PACKv2 file in OCaml |
0.7.0 → 1.4.0 |
1 | 10 | 2 | 10 | single outdated | ||
Implementation of PACKv2 file in OCaml |
0.7.0 → 0.7.2 |
1 | 14 | 1 | 9 | single outdated | ||
Implementation of PACKv2 file in OCaml |
0.7.0 → 1.4.0 |
1 | 22 | 3 | 11 | single outdated | ||
Date and time field types using the calendar library |
2.3.2 → 3.0.0 |
1 | 7 | 0 | 0 | single outdated | ||
Miou support for Caqti |
2.3.2 → 3.0.0 |
1 | 8 | 0 | 0 | single outdated | ||
Lwt support for Caqti |
2.3.2 → 3.0.0 |
1 | 8 | 1 | 4 | single outdated | ||
Eio support for Caqti |
2.3.2 → 3.0.0 |
1 | 8 | 0 | 0 | single outdated | ||
Dynamic linking of Caqti drivers using findlib.dynload |
2.3.2 → 3.0.0 |
1 | 6 | 0 | 0 | single outdated | ||
Sqlite3 driver for Caqti using C bindings |
2.3.2 → 3.0.0 |
1 | 9 | 0 | 0 | single outdated | ||
PostgreSQL driver for Caqti based on C bindings |
2.3.2 → 3.0.1 |
1 | 7 | 0 | 0 | single outdated | ||
MariaDB driver for Caqti using C bindings |
2.3.2 → 3.0.1 |
1 | 7 | 0 | 0 | single outdated | ||
Async support for Caqti |
2.3.2 → 3.0.0 |
1 | 9 | 0 | 0 | single outdated | ||
Unified interface to relational database libraries |
2.3.2 → 3.0.0 |
1 | 16 | 9 | 13 | single outdated | ||
Unix helpers for Cap'n Proto RPC services |
2.1.2-unstable-2026-09-13 |
1 | 21 | 0 | 0 | single | ||
Network and TLS support for Cap'n Proto RPC services |
2.1.2-unstable-2026-09-13 |
1 | 21 | 1 | 1 | single | ||
Cap'n Proto RPC library for OCaml |
2.1.2-unstable-2026-09-13 |
1 | 14 | 2 | 2 | single | ||
OCaml code generation plugin for the Cap'n Proto serialization framework |
3.6.0 |
1 | 13 | 3 | 3 | single | ||
Unicode library for OCaml |
2.0.0 → 2.1.0 |
1 | 7 | 4 | 4 | single outdated | ||
Preprocessor-pretty-printer for OCaml |
8.05.02 |
1 | 12 | 3 | 11 | single | ||
Stream and Genlex libraries for use with Camlp4 and Camlp5 |
5.0.1 |
1 | 5 | 36 | 189 | single | ||
OCaml image processing library |
5.0.5 |
1 | 9 | 0 | 0 | single | ||
Stub code generator and COM binding for Objective Caml |
1.12 → 1.13-1 |
1 | 4 | 7 | 17 | single outdated | ||
OCaml interface to Alan Murta's General Polygon Clipper |
1.2 |
1 | 5 | 0 | 0 | single | ||
Curve25519 in OCaml |
0.2 |
1 | 8 | 0 | 0 | single | ||
Library for handling dates and times |
3.0.0 |
1 | 6 | 6 | 178 | single | ||
A simple cache system for mmap and lwt |
0.0.2 → 0.0.4 |
1 | 8 | 0 | 0 | single outdated | ||
A simple cache system for mmap |
0.0.2 → 0.0.4 |
1 | 6 | 2 | 3 | single outdated | ||
X.509 trust anchors extracted from Mozilla's NSS |
3.129-1 |
1 | 13 | 5 | 17 | single | ||
Detect root CA certificates from the operating system |
1.0.3 |
1 | 15 | 6 | 31 | single | ||
Composable, memory efficient, byte stream readers and writers compatible with effect-based concurrency |
0.4.1 |
1 | 13 | 2 | 7 | single | ||
Backward Lists |
2.3.0 |
1 | 6 | 3 | 3 | single | ||
A simple library for bigstrings |
0.1.1 |
1 | 5 | 4 | 25 | single | ||
Toolkit for programming browsers in OCaml |
0.0.9 |
1 | 9 | 3 | 10 | single | ||
Basic OS interaction for OCaml |
0.3.0 |
1 | 12 | 22 | 206 | single | ||
Implementation of BLS signatures for the pairing-friendly curve BLS12-381 |
1.0.0 |
1 | 9 | 0 | 0 | single | ||
Functors to generate BLS12-381 primitives based on stubs |
0.4.4 → 0.5.0 |
1 | 7 | 0 | 0 | single outdated | ||
Implementation of BLS12-381 and some cryptographic primitives built on top of it |
6.1.0 → 20.1 |
1 | 11 | 1 | 1 | single outdated | ||
Blocking API for the jack audio connection kit |
0.1.6 |
1 | 8 | 0 | 0 | single | ||
OCaml binding for the SMT solver Bitwuzla C++ API |
0.8.2 → 0.9.1 |
1 | 6 | 2 | 3 | single outdated | ||
Bit vector library for OCaml |
2.1 |
1 | 5 | 0 | 0 | single | ||
This library adds Erlang-style bitstrings and matching over bitstrings as a syntax extension and library for OCaml |
5.0.2 |
1 | 6 | 2 | 2 | single | ||
Build and execute typed scientific workflows |
unstable-2024-05-17 → 0.6.0 |
1 | 16 | 0 | 0 | single broken outdated | ||
Datastructure to accumulate values in bins |
0.0.0 |
1 | 5 | 1 | 2 | single | ||
Binary data format designed for speed, safety, ease of use and backward compatibility as protocols evolve |
1.2.2 |
1 | 7 | 2 | 13 | single | ||
Efficient binder representation in Ocaml |
6.0.0 |
1 | 7 | 0 | 0 | single | ||
Bigstring intrinsics and fast blits based on memcpy/memmove |
0.10.0 |
1 | 8 | 26 | 201 | single | ||
Minimal library to know that 2 bigarray share physically the same memory or not |
0.2.1 |
1 | 7 | 2 | 13 | single | ||
Compatibility library to use Stdlib.Bigarray when possible |
1.1.0 |
1 | 5 | 7 | 91 | single | ||
OCaml binary heap implementation by Jean-Christophe Filliâtre |
2.0.0 |
1 | 6 | 2 | 15 | single | ||
Bencode (.torrent file format) reader/writer in OCaml |
2.0 |
1 | 7 | 1 | 1 | single | ||
Quick implementation of a Binary Decision Diagrams (BDD) library for OCaml |
0.5 |
1 | 6 | 0 | 0 | single | ||
Base64 encoding and decoding in OCaml |
3.5.2 |
1 | 8 | 45 | 169 | single | ||
Base32 for Ocaml |
1.0.0 |
1 | 8 | 2 | 2 | single | ||
Platform for binary analysis. It is written in OCaml, but can be used from other languages |
2.5.0+pr1621 → 2.5.0 |
1 | 37 | 0 | 0 | single outdated | ||
Exponential backoff mechanism for OCaml |
0.1.1 |
1 | 6 | 4 | 7 | single |