master · x86_64-linux · 9a32621949da · generated 2026-10-09T00:54:19Z
102,196packages 38,710unmaintained (37.9%) 41,823single maintainer (40.9%) 9,522team only (9.3%) 8,403broken 12,567outdated (12.3%) 4,913maintainers 85teams 206setup hooks (hidden)
Reset

1,220 packages · page 1 of 13

Package ▼ Version Maintainers # Teams Deps Used by Used by (transitive) Status
OCaml bindings to Zstandard
0.17.0
0
9 1 1 unmaintained
ZeroMQ bindings for OCaml
5.3.0 → 6.0.0
1
7 0 0 single outdated
ZeroMQ bindings for OCaml
5.3.0 → 6.0.0
1
7 4 7 single outdated
ZIP archive and deflate codec for OCaml
0.2.0
1
8 0 0 single
Zelus GTK library
2.2
1
7 0 0 single unfree
Synchronous language with ODEs
2.2
1
7 1 1 single unfree
Abstract engine for text edition in OCaml
3.2.3
1
11 3 7 single
Javascripts stubs for the Zarith library
0.17.0
0
6 5 11 unmaintained
Fast, arbitrary precision OCaml integers
1.14
2
6 54 153 maintained
Z3 Theorem Prover (OCaml API)
5.1.0
2
4 4 7 maintained
Name pattern combinators
5.2.0
1
8 1 1 single
Simple mapper between UTF-7 to Unicode according RFC2152
0.3.0
0
9 1 4 unmaintained
Optimized parsing and printing library for the JSON format
2.2.2
1
6 1 1 single
Optimized parsing and printing library for the JSON format
3.0.0
1
5 60 370 single
Pure-OCaml YAML 1.2 parser with a lossless, comment-preserving AST
0.5.0
1
7 2 13 single
ocaml-yaml with sexp support
3.2.0
1
9 1 1 single
Parse and generate YAML 1.1 files
3.2.0
1
15 5 10 single
Bindings for xxHash, an extremely fast hash algorithm
0.2
1
10 1 8 single
Xml templating library, ppx extension
1.1.0 → 1.2.0
1
7 1 3 single outdated
XML templating library for OCaml
1.1.0 → 1.2.0
1
10 3 5 single outdated
Module to parse various RSS playlist formats
0.1.5
1
7 1 1 single
OCaml streaming codec to decode and encode the XML data format
1.4.0
1
7 9 221 single
Minimal Xml parser and printer for OCaml
2.5
1
5 4 15 single
OCaml bindings to libxkbcommon
0.1.0
1
9 0 0 single
Low-level libraries for connecting to a xenstore service on a xen host
1.5.0
4 7 2 5 team-only
Command line tool for interfacing with xenstore
1.5.0
4 9 0 0 team-only
Xenstore protocol in pure OCaml
2.3.0 → 2.4.0
5 7 5 9 maintained outdated
XDG Base Directory Specification
3.23.1 → 3.24.2
1
5 4 67 single outdated
X509 (RFC5280) handling in OCaml
1.2.0
0
18 15 67 unmaintained
WTF-8 is a superset of UTF-8 that allows unpaired surrogates
1.0.2
1
5 0 0 single
Unit tests, property-based tests, snapshot tests, and expect tests in a single package with one API.
0.1.0 → 0.2.0
1
5 0 0 single outdated
REST toolkit for OCaml
0.7.0
1
9 0 0 single
Open and reload URIs in browsers from OCaml
0.6.2
1
11 0 0 single
Pure OCaml Wayland protocol library
2.3
1
13 1 1 single
Compiler from OCaml bytecode to WebAssembly
6.4.1
1
13 0 0 team-only
Verified Polyhedra Library
0.5
1
6 0 0 single
Bindings to libvorbis
1.0.0
1
8 0 0 single
Encoding variable-length quantities, in particular base64
0.2.1
1
6 0 0 single broken
OCaml syntax extension (technically, a ppx_deriving plugin) which generates object-oriented visitors for traversing and transforming data structures
20251010 → 20260520
0
8 4 4 unmaintained outdated
OCaml bindings for the floating positioning library for 'toplevel' virtual dom components
0.17.0
0
10 0 0 unmaintained
OCaml bindings for the virtual-dom library
0.17.0
0
11 4 5 unmaintained broken
Declarative 2D vector graphics for OCaml
0.9.5
1
12 1 2 single
Helper functions for creating stable/versioned `Polling_state_rpc.t`s with babel
0.17.0
0
10 1 1 unmaintained
Resizable arrays for OCaml
1.0.0
1
5 3 16 single
Elm architecture and (V)DOM for OCaml
0.3
1
8 0 0 single
Xen Vchan implementation
6.0.2
5 12 1 3 maintained
OCaml bindings for the Neovim API
0.17.0
0
13 0 0 unmaintained
Part of Jane Street's Core library
0.17.0
0
6 1 147 unmaintained
Library to normalize an ISO-8859 input to Unicode code-point
0.4.0
0
5 1 4 unmaintained
Non-blocking streaming Unicode codec for OCaml
1.0.4
1
9 55 844 single
OCaml library for segmenting Unicode text
18.0.0
1
10 18 26 single
OCaml module for normalizing Unicode text
18.0.0
1
9 6 214 single
OCaml module implementing 128 bits universally unique identifiers version 3, 5 (name based with MD5, SHA-1 hashing) and 4 (random based) according to RFC 4122
0.9.10
1
8 7 20 single
OCaml library providing efficient access to a selection of character properties of the Unicode character database
18.0.0
1
11 9 206 single
OCaml module to decode the data of the Unicode character database from its XML representation
18.0.0
1
8 1 207 single
Universal toplevel for OCaml
2.17.0
1
11 3 4 single
Identifier for a user
0.17.0
0
7 0 0 unmaintained
Bindings to io_uring for OCaml
2.15.0
1
10 1 12 single
RFC3986 URI parsing library for OCaml
4.4.0
1
9 7 48 single
RFC3986 URI parsing library for OCaml
4.4.0
1
8 45 120 single
[option]-like type that incurs no allocation
0.17.0
0
7 1 99 unmaintained
Library for parsing email headers
0.5
0
14 4 12 unmaintained
Unix errno types, maps, and support for OCaml
0.6.2
1
8 0 0 single
UNISIM-VP DBA decoder
0.0.13 → 0.0.14
1
5 0 0 single outdated
Implementations of the union-find data structure
20250818 → 20260226
1
5 3 7 single outdated
Lexer generator for Unicode and OCaml
1.2 → 1.3
1
6 1 1 single broken outdated
Bindings for ECDH and ECDSA for 8-bit, 32-bit, and 64-bit processors
0.4
1
9 0 0 single
Compatibility library for OCaml’s Uchar module
0.0.2
1
6 5 845 single
Remove accents from utf8 strings
0.20
1
5 0 0 single
Make reactive webpages in Js_of_ocaml using Tyxml and Lwd
0.5
1
9 0 0 single
Library that makes it almost impossible for your OCaml programs to generate wrong XML output, using static typing
4.6.0 → 5.0.0
2
7 12 38 maintained outdated
Typed Regular Expressions
0.5 → 1.0
1
9 1 1 single outdated
Typerep is a library for runtime types
0.17.1
0
6 1 143 unmaintained
The essence of OCaml types as values
0.0.0
1
7 1 6 single
Type identifiers, useful for runtime type-safe casting/coersions
0.0.1
1
7 0 0 single
Type equality proofs for OCaml 4
0.0.1
1
6 1 1 single
“The Whitespace Thing” for OCaml
0.94.0
1
4 0 0 single broken
Bindings to the UNIX tuntap facility
2.0.2
0
7 0 0 unmaintained
Library for interacting with teletype and terminal emulators
0.0.2
1
6 2 7 single
Easy to use and user-friendly topological sort
2.2.0
1
6 1 1 single
SDL2_ttf bindings for Ocaml with Tsdl
0.6 → 0.7
0
9 0 0 unmaintained outdated
SDL2_mixer bindings to go with Tsdl
0.6
0
9 0 0 unmaintained
OCaml SDL2_image bindings to go with Tsdl
0.6
0
9 0 0 unmaintained
Thin bindings to the cross-platform SDL library
1.2.0 → 1.3.0
0
11 3 3 unmaintained outdated
Strict impure trie tree
1.0.0
1
5 1 9 single
Simple backend for trace, emitting Catapult JSON into a file
0.12
1
7 0 0 single
Common interface for tracing/instrumentation libraries in OCaml
0.12
1
5 2 5 single
Topological sort algorithm
0.17.0
0
7 0 0 unmaintained
Packager for distributing OCaml software
1.1.0 → 1.1.1
1
6 37 906 single outdated
Dune's topological closure library
3.23.1 → 3.24.2
1
5 1 99 single outdated
Implementation in OCaml of the Toml minimal language
7.1.0
1
7 4 4 single
Transport Layer Security purely in OCaml, MirageOS layer
2.1.3
1
14 6 19 single
Transport Layer Security purely in OCaml, Miou+Unix layer
2.1.3
1
14 2 2 single
TLS in pure OCaml
2.1.3
1
8 3 4 single
TLS in pure OCaml
2.1.3
1
12 2 3 single
Transport Layer Security purely in OCaml, Async layer
2.1.3
1
10 0 0 single
TLS in pure OCaml
2.1.3
1
20 14 36 single
Minimal HTTP server using good old threads
0.16 → 0.22
1
7 1 1 single outdated
Time-zone handling
0.17.0
0
6 2 60 unmaintained
Virtual library for Timedesc local time zone detection backends
3.1.2
1
5 1 3 single