vbgl Vincent Laporte
github.com/vbgl · maintains 464 packages (463 directly), sole maintainer of 388, member of 0 teams
388 packages · page 2 of 4
| Package ▲ | Version | Maintainers | # | Teams | Deps | Used by | Used by (transitive) | Status |
|---|---|---|---|---|---|---|---|---|
Pure DNS resolver API |
10.2.6 |
1 | 16 | 1 | 1 | single | ||
DNS client API for Miou |
10.2.6 |
1 | 12 | 1 | 1 | single | ||
Pure DNS resolver API |
10.2.6 |
1 | 18 | 3 | 13 | single | ||
Opinionated Domain Name System (DNS) library |
10.2.6 |
1 | 10 | 4 | 5 | single | ||
DNS resolver business logic |
10.2.6 |
1 | 22 | 2 | 2 | single | ||
DNS server, primary and secondary |
10.2.6 |
1 | 18 | 3 | 3 | single | ||
DNS stub resolver |
10.2.6 |
1 | 18 | 0 | 0 | single | ||
TSIG support for DNS |
10.2.6 |
1 | 9 | 5 | 7 | single | ||
DNSSec support for OCaml-DNS |
10.2.6 |
1 | 13 | 2 | 3 | single | ||
OCaml library providing clean and flexible parsers for input languages |
0.10 |
1 | 9 | 4 | 6 | single | ||
Tool library for automated deduction tools |
0.10 |
1 | 10 | 2 | 4 | single | ||
Dolmen library for verifying models generated by automated theorem provers and SMT solvers |
0.10 |
1 | 10 | 1 | 2 | single | ||
Typechecker for automated deduction languages |
0.10 |
1 | 8 | 3 | 5 | single | ||
Minimalistic lazy logger in OCaml |
6.0.0 |
1 | 5 | 0 | 0 | single | ||
Scheduler independent timeout mechanism |
1.0.1 |
1 | 11 | 1 | 3 | single | ||
RFC 1035 Internet domain names |
0.5.0 |
1 | 6 | 21 | 136 | single | ||
Non-parallel implementation of Domains compatible with OCaml 4 |
0.1.0 |
1 | 5 | 3 | 33 | single | ||
Nested-parallel programming |
0.5.2 |
1 | 10 | 1 | 1 | single | ||
Tidy, feature-complete Web framework |
1.0.0-alpha8 |
1 | 27 | 3 | 3 | single | ||
Shared http/af stack for Dream (server) and Hyper (client) |
1.0.0-alpha8 |
1 | 8 | 1 | 4 | single | ||
Shared HTTP types for Dream (server) and Hyper (client) |
1.0.0-alpha8 |
1 | 11 | 2 | 5 | single | ||
Traced atomics |
0.6.0 |
1 | 6 | 2 | 5 | single | ||
Pure OCaml implementation of libXdiff (Rabin’s fingerprint) |
0.5 |
1 | 10 | 1 | 12 | single | ||
Conversions to various time units |
0.3.1 |
1 | 6 | 20 | 102 | single | ||
Dynamic type |
3.23.1 → 3.24.2 |
1 | 7 | 6 | 100 | single outdated | ||
Parser combinators based on Earley Algorithm |
3.0.0 |
1 | 6 | 1 | 1 | single | ||
High-level and functional interface to the Format module of the OCaml standard library |
1.3.4 |
1 | 5 | 4 | 20 | single | ||
ETH LIbrary for Numerical Analysis |
1.1 → 1.3.2 |
1 | 10 | 0 | 0 | single outdated | ||
Embeddable λProlog Interpreter |
3.8.0 |
1 | 15 | 0 | 0 | single | ||
Library to generate encoder/decoder which ensure isomorphism |
0.8.1 |
1 | 9 | 1 | 9 | single | ||
Constant time equal function to avoid timing attacks in OCaml |
0.10 |
1 | 5 | 6 | 120 | single | ||
Constant time equal function to avoid timing attacks in OCaml |
0.10 |
1 | 7 | 0 | 0 | single | ||
XML Parser for discrete data |
0.3+20180112 |
1 | 5 | 1 | 1 | single broken | ||
Easy interface on top of the Jsonm library |
1.3.0 |
1 | 8 | 10 | 22 | single | ||
Serialization library built for speed and memory efficiency |
0.8.2 |
1 | 7 | 15 | 53 | single | ||
Async support for Faraday |
0.8.2 |
1 | 8 | 1 | 1 | single | ||
Lwt support for Faraday |
0.8.2 |
1 | 7 | 2 | 11 | single | ||
Lwt + Unix support for Faraday |
0.8.2 |
1 | 7 | 3 | 9 | single | ||
Printf-like for Faraday library |
0.3 |
1 | 8 | 0 | 0 | single | ||
OCaml API to manipulate real files (POSIX like) and filenames |
0.6.6 |
1 | 8 | 5 | 9 | single | ||
Simple OCaml module for computing the least solution of a system of monotone equations |
20250919 |
1 | 5 | 17 | 40 | single | ||
OCaml Format pretty-printer combinators |
0.11.0 |
1 | 8 | 126 | 835 | single | ||
Fontconfig bindings for OCaml |
unstable-2013-11-03 |
1 | 5 | 0 | 0 | single | ||
OCaml module for handling file system paths with POSIX and Windows conventions |
0.7.3 |
1 | 8 | 36 | 269 | single | ||
Dune's file system IO library |
3.23.1 → 3.24.2 |
1 | 5 | 1 | 99 | single outdated | ||
Distributed computing library for Objective Caml which facilitates distributed execution of parallelizable computations in a seamless fashion |
0.6 |
1 | 4 | 1 | 1 | single broken | ||
Heterogenous maps over a GADT |
0.3.0 |
1 | 7 | 2 | 75 | single | ||
Build GraphQL schemas and execute queries against them |
0.14.0 |
1 | 9 | 2 | 8 | single | ||
Run GraphQL servers with “cohttp” |
0.14.0 |
1 | 14 | 1 | 2 | single | ||
Build GraphQL schemas with Lwt support |
0.14.0 |
1 | 8 | 3 | 7 | single | ||
Library for parsing GraphQL queries |
0.14.0 |
1 | 9 | 1 | 9 | single | ||
OCaml bindings to the GNU Scientific Library |
1.25.1 |
1 | 8 | 2 | 2 | single | ||
High-performance, memory-efficient, and scalable web server for OCaml |
1.1.1 |
1 | 11 | 5 | 13 | single | ||
Minimal OCaml library providing hexadecimal converters |
1.5.0 |
1 | 6 | 14 | 74 | single | ||
CoHTTP implementation using the Lwt concurrency library |
6.3.0 |
1 | 5 | 3 | 37 | single | ||
HTTP client for MirageOS |
0.0.11 |
1 | 13 | 1 | 1 | single | ||
High-performance, memory-efficient, and scalable web server for OCaml |
0.7.1 |
1 | 9 | 4 | 4 | single | ||
Lwt support for http/af |
0.7.1 |
1 | 8 | 1 | 1 | single | ||
High-performance, memory-efficient, and scalable HTTP library for OCaml |
0.2.0 |
1 | 10 | 3 | 11 | single | ||
EIO support for httpun |
0.2.0 |
1 | 7 | 1 | 1 | single | ||
Lwt support for httpun |
0.2.0 |
1 | 9 | 1 | 5 | single | ||
Lwt + Unix support for httpun |
0.2.0 |
1 | 7 | 1 | 4 | single | ||
Common HTTP/1.x types |
0.2.0 |
1 | 6 | 3 | 30 | single | ||
Websocket implementation for httpun |
0.2.0 |
1 | 12 | 4 | 7 | single | ||
Lwt support for httpun-ws |
0.2.0 |
1 | 9 | 0 | 0 | single | ||
Image formats such as PNG and PPM in OCaml |
20221222 |
1 | 8 | 0 | 0 | single | ||
Platform-agnostic multi-level index |
1.6.2 |
1 | 19 | 1 | 2 | single | ||
Bindings for Linux’s filesystem monitoring interface, inotify |
2.6 |
1 | 8 | 1 | 2 | single | ||
Various signed and unsigned integer types for OCaml |
0.8.0 |
1 | 6 | 7 | 73 | single | ||
IO memory page library for Mirage backends |
3.0.0 |
1 | 9 | 5 | 8 | single | ||
IRI (RFC3987) native OCaml implementation |
1.2.0 |
1 | 8 | 1 | 6 | single | ||
Portable Irmin watch backends using FSevents or Inotify |
0.5.0 |
1 | 9 | 3 | 5 | single | ||
ISO 8601 and RFC 3999 date parsing for OCaml |
0.2.5 |
1 | 5 | 5 | 10 | single | ||
Library that parses Java .class files into OCaml data structures |
3.2.2 |
1 | 7 | 1 | 2 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 14 | 39 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 11 | 7 | 312 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 8 | 5 | 7 | single | ||
Ocamlbuild plugin to compile to JavaScript |
5.0 |
1 | 6 | 1 | 3 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 8 | 21 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 3 | 3 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 7 | 1 | 11 | single | ||
Compiler from OCaml bytecode to Javascript |
6.4.1 |
1 | 9 | 1 | 3 | single | ||
OCaml non-blocking streaming codec to decode and encode the JSON data format |
1.0.2 |
1 | 8 | 8 | 73 | single | ||
Implementation of JSON Web Signature/Token (RFC 7515) |
0.0.2 |
1 | 13 | 1 | 4 | single | ||
OCaml bindings for Kafka |
0.5 |
1 | 7 | 1 | 1 | single broken | ||
OCaml bindings for Kafka, Lwt bindings |
0.5 |
1 | 8 | 0 | 0 | single broken | ||
STM based on lock-free MCAS |
0.7.0 |
1 | 9 | 1 | 2 | single | ||
Key Derivation Functions: HKDF RFC 5869, PBKDF RFC 2898, SCRYPT RFC 7914 |
1.1.2 |
1 | 9 | 2 | 68 | single | ||
Fast implementation of queue in OCaml |
0.6 |
1 | 8 | 11 | 32 | single | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 4 | 13 | single outdated | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 0 | 0 | single outdated | ||
OCaml interface to Gnome rsvg2 library |
3.1.5 |
1 | 9 | 0 | 0 | single | ||
OCaml interface to GTK 3 |
3.1.5 → 3.1.5-1 |
1 | 10 | 2 | 9 | single outdated | ||
OCaml interface to Tcl/Tk, including OCaml library explorer OCamlBrowser |
1 | 7 | 0 | 0 | single broken | |||
OCaml bindings for BLAS and LAPACK |
11.1.1 |
1 | 8 | 1 | 1 | single | ||
Functional HTML scraping and rewriting with CSS in OCaml |
1.1.1 |
1 | 8 | 6 | 15 | single | ||
OCaml bindings to linenoise |
1.5.1 |
1 | 6 | 4 | 5 | single | ||
OCaml bindings distributed with LLVM |
21.1.8 |
1 | 8 | 0 | 0 | single | ||
Logs reporter to syslog (UDP/TCP/TLS) |
0.5.0 |
1 | 8 | 1 | 6 | single | ||
Scalable LRU caches for OCaml |
0.3.1 |
1 | 7 | 9 | 56 | single |