master · x86_64-linux · 64481e9d53f4 · generated 2026-10-13T00:45:59Z
102,313packages 37,781unmaintained (36.9%) 41,885single maintainer (40.9%) 9,536team only (9.3%) 8,404broken 12,350outdated (12.1%) 4,930maintainers 85teams 206setup hooks (hidden)
Reset

11,646 packages · page 88 of 117

Package ▲ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Tool for automatically reordering python imports
3.18.0
1
18 0 0 single
Simple regex-based lexer/parser for inline markup
1.4.3
1
13 0 0 single
Port of the node module path-to-regexp to Python
0.9.0
1
14 1 4 single
Unittest-compatible framework for repeating a test function over many fixtures
2.3.3
0
17 3 5 unmaintained
Python REPL plugin for automatic time tracking and metrics generated from your programming activity
0.1.6
1
22 0 0 single
Python client for Replicate
1.1.0b3 → 1.0.7
1
24 0 0 single outdated
Open Source Python library for generating PDFs and graphics
5.0.1
0
18 17 27 unmaintained
Allows to create QR codes for use with the ReportLab PDF library
0.1.6
1
19 0 0 single
Tiny LRU cache implementation and decorator
0.7 → 0.8
0
17 4 24 unmaintained outdated
Auto-generate Sphinx API docs from Zope interfaces
1.0.0 → 1.1.0
0
20 0 0 unmaintained broken outdated
WSGI Authentication Middleware / API
3.1.0 → 3.2.0
0
19 0 0 unmaintained outdated
Module for binding variables and refreshing multi-line output in terminal
0.6.0
2
18 1 1 maintained
Reproject astronomical images
0.21.0
1
36 2 4 single
Toolshed for writing great __repr__ methods quickly and easily
1.0.6
1
13 1 2 single
Module to do automated pentest reporting with SysReptor
0.34 → 0.38
1
33 0 0 single outdated
Python library for ReqIF format
0.0.54 → 0.1.0
0
21 0 0 unmaintained outdated
HTTP library for Python
2.34.2
1
24 1,263 6,697 single
Amazon Web Services version 4 authentication for the Python Requests library
1.3.2 → 1.4.0
1
19 1 1 single outdated
Persistent cache for requests library
1.3.3
1
31 7 25 single
HTTPS CredSSP authentication with the requests library
2.0.0
1
20 1 3 single
Download files using requests and save them to a target path
0.1.2
0
17 0 0 unmaintained
Transport adapter for fetching file:// URLs with the requests python library
2.1.0 → 3.0.1
0
19 2 30 unmaintained outdated
Asynchronous Python HTTP Requests for Humans using Futures
1.0.2 → 1.1.0
1
22 2 1,620 single outdated
GSSAPI authentication handler for python-requests
1.4.0
1
19 1 1 single
Library that adds hardened behavior to python requests
1.3.0
1
22 0 0 single
Hawk authentication strategy for the requests python library
1.2.1
1
15 0 0 single
Request authentication plugin implementing IETF HTTP Message Signatures
0.3.0
4 19 0 0 team-only
Requests authentication module for HTTP Signature
0.7.1
0
18 0 0 unmaintained
Authentication handler for using Kerberos with Python Requests
0.15.0
0
20 5 44 unmaintained
Mock out responses from the requests package
1.12.1
0
23 132 1,619 unmaintained
HTTP NTLM authentication support for python-requests
1.3.0
0
19 4 6 unmaintained
OAuthlib authentication support for Requests
2.0.0
1
18 41 247 single
PKCS#12 support for the Python requests library
1.27
1
15 1 1 single
Configures the requests library to randomly select a desktop User-Agent
2025.01.19
1
18 0 0 single
Module for rate-limiting for requests
0.10.0
0
21 2 9 unmaintained
Server-sent events python client library based on requests
0.5.3
4 17 0 0 maintained
Toolbelt of useful classes and functions to be used with requests
1.0.0
1
21 40 640 single
Use requests to talk HTTP via a UNIX domain socket
0.4.1 → 1.0.1
0
20 2 30 unmaintained outdated
Use requests to talk HTTP via a UNIX domain socket
1.0.1
1
20 1 1 single
WSGI Transport Adapter for Requests
0.4.1
1
14 1 1 single
Import exceptions from potentially bundled packages in requests
1.4.0
1
14 0 0 single
Python tool to find and list requirements of a Python project
1.3.2 → 1.6.0
1
20 0 0 single outdated
Pip requirements file parser
0.13.1
0
18 4 4 unmaintained
Easy to use retry decorator
0.11.8
1
13 2 2 single
Implementation helper for running rerun-sdk in notebooks
0.38.1 → 0.39.0
2
18 1 1 maintained outdated
Python bindings for `rerun` (an interactive visualization tool for stream data)
0.38.1 → 0.39.0
2
37 0 0 maintained outdated
Efficient signal resampling
0.4.3
0
21 3 37 unmaintained
SDK for Resend
2.45.0 → 2.49.1
1
20 0 0 single outdated
Commandline utility to resize an image
0.4.0 → 1.1.20
1
18 1 1 single outdated
Correct way to resize images or tensors. For Numpy or Pytorch (differentiable
0.0.2
1 15 0 0 team-only
Resolve abstract dependencies into concrete ones
1.2.1
0
18 3 13 unmaintained
Python module for mocking out the requests Python library
0.26.2 → 0.26.3
1
25 112 1,328 single outdated
Python library for mocking HTTPX
0.23.1
1
24 37 995 single
Python RESTfly API Library Framework
2.0.3
1
26 1 1 single
Restricted execution environment for Python to run untrusted code
8.5
1
18 0 0 single
reStructuredText linter
2.0.2
0
18 3 6 unmaintained
ReStructuredText viewer
3.0.2
1
22 0 0 single
Rust-like result type for Python
0.17.0
0
19 1 2 unmaintained
High level wrapper of resvg for python
0.5.0
0
19 0 0 unmaintained
Python driver library for the RethinkDB database server
2.4.10.post1
0
18 0 0 unmaintained
Deep Face Detection Library for Python
0.0.17 → 0.0.19
1
24 1 1 single outdated
Easy to use retry decorator
0.9.2 → 0.9.5
0
18 2 3 unmaintained outdated
Decorator for retrying when exceptions occur
1.1.1
0
14 0 0 unmaintained
Retry decorator
0.9.5
1
18 2 2 single
Retry potentially transient HTTP errors in Python
1.4.0 → 1.5.0
1
22 0 0 single outdated
General-purpose retrying library
1.4.2
0
17 4 10 unmaintained
Make your functions return something meaningful, typed, and safe
0.29.0
1
29 0 0 single
Commonly consumed code commodities for Python
1.0.0
1
19 0 0 single
Tool for compliance with the REUSE Initiative recommendations
6.2.0
2
32 0 0 maintained
Reverse geocode the given latitude/longitude
1.6.6
1
18 1 1 single
Library to decode and encode radio frequency signals
4.3.0
1
19 0 0 single
Opinionated Python RFC3161 Client
1.0.9
1
20 2 5 single
Format dates according to the RFC 3339
6.2
1
13 2 2 single
RFC 3339 validator for Python
0.1.4
0
17 6 693 unmaintained
Validating URI References per RFC 3986
2.0.0
0
15 5 384 unmaintained
Pure python rfc3986 validator
0.1.1
0
16 2 139 unmaintained
Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
1.3.8
1
13 3 142 single
Helper functions to syntactically validate strings according to RFC 3987
1.1.0
0
18 2 139 unmaintained
Python implementation of the Happy Eyeballs Algorithm
0.1.0
0
14 0 0 unmaintained
RFC 7464 is a proposed standard for streaming JSON documents
17.7.0
1
14 0 0 single
Module for RFC8785 (JSON Canonicalization Scheme)
0.1.4
1
17 2 4 single
Swiss Army knife of sub-GHz ISM band radio
3.0.0
0
22 0 0 unmaintained
RFK101 Proximity card reader over Ethernet
0.0.1
1
16 0 0 single
Library and CLI tools for interacting with RFlink 433MHz transceiver
0.0.68
1
20 0 0 single
RGB conversion tool written in Python for Philips Hue
0.5-unstable-2025-12-16
1
15 1 2 single
Linux C libraries and Python modules for manipulating GPIO
0.2.2
1
13 0 0 single
Render rich text, tables, progress bars, syntax highlighting, markdown and more to the terminal
15.0.0
1
21 206 3,877 single
Format argparse help output using rich
1.7.2 → 1.8.0
1
18 4 69 single outdated
Library to help formatting argparse
0.3.1.4
1
18 0 0 single
Module to format click help output nicely with rich
1.9.9
1
20 7 30 single
Rich-compatible library for writing pixel images and ASCII art to the terminal
3.0.1
0
21 0 0 unmaintained
Beautiful reStructuredText renderer for rich
2.1.0 → 2.2.0
0
19 1 14 unmaintained outdated
Ready-made rich tables for various purposes
0.10.0
1
29 1 1 single
Define custom styles and themes for use with rich
0.11.0
1
18 1 1 single
Rich toolkit for building command-line applications
0.20.1 → 0.20.6
0
22 2 565 unmaintained outdated
Module for Riden RD power supplies
1.2.1
1
21 1 1 single
Data cleaning and validation functions for names, languages, identifiers, etc
1.8.2 → 2.5.0
1
30 0 0 single outdated
Library to communicate with Ring Door Bell
0.9.14
1
32 0 0 single
Create STAC Items from raster datasets
0.12.0
1
20 0 0 single
User friendly Rasterio plugin to read raster datasets
9.4.7 → 9.4.12
7 35 0 0 team-only outdated