master · x86_64-linux · e7fccb1ad3ed · generated 2026-10-17T01:00:33Z
102,550packages 37,779unmaintained (36.8%) 41,932single maintainer (40.9%) 9,663team only (9.4%) 8,445broken 11,466outdated (11.2%) 4,941maintainers 85teams 207setup hooks (hidden)
Reset

41,932 packages · page 227 of 420

Package ▲ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Python reflink wraps around platform specific reflink implementations
0.2.2
1
14 3 25 single
Python wrapper for reflink_copy Rust library
0.3.3
1
16 0 0 single
Refoss support for Home Assistant
1.2.5 → 1.2.6
1
16 0 0 single outdated
Python library for interacting with RainMachine smart sprinkler controllers
2024.03.0
1
24 0 0 single
Alternative regular expression module, to replace re
2026.8.12
1
16 77 3,547 single
Python bindings to the Rust regress crate, exposing ECMA regular expressions
2026.9.1
1
15 0 0 single
Nested Object Models in Python
0.7.3
1
21 0 0 single
Templating library able to output odt and pdf files
0.12.1
1
21 1 1 single
Sphinx extension for changelog manipulation
2.1.1
1
15 1 1 single
Tool to remove background from images
2.0.85
1
27 0 0 single
Pythonic, lightweight and websocket-based webui library
2022.7.27
1
21 0 0 single
Remote vanilla PDB (over TCP sockets)
2.1.0
1
13 0 0 single
Python module to access single members of a zip archive without downloading the full content
0.12.5 → 0.12.6
1
19 2 4 single outdated
Access zip file content hosted remotely without downloading the full file
0.0.2
1
18 1 2 single
Python library to interact with the Renault API
0.5.15 → 0.6.1
1
29 0 0 single outdated
One canvas API, multiple backends
2.7.2
1
22 0 0 single
Python package with some fonts for the rendercv package
0.5.1
1
17 0 0 single
Module to interact with Renson endura delta
1.7.2
1
17 0 0 single
Module to interact with the Reolink IP camera API
0.0.64 → 0053
1
19 0 0 single outdated
Module to interact with the Reolink IP camera API
0.21.18
1
21 0 0 single
Tool for automatically reordering python imports
3.18.0 → 3.19.0
1
18 0 0 single outdated
Simple regex-based lexer/parser for inline markup
1.4.3
1
13 0 0 single
Port of the node module path-to-regexp to Python
0.9.0
1
14 1 4 single
Python REPL plugin for automatic time tracking and metrics generated from your programming activity
0.1.6
1
22 0 0 single
Python client for Replicate
1.1.0b3 → 1.0.7
1
24 0 0 single outdated
Allows to create QR codes for use with the ReportLab PDF library
0.1.6
1
19 0 0 single
Reproject astronomical images
0.21.0
1
36 2 4 single
Toolshed for writing great __repr__ methods quickly and easily
1.0.6
1
13 1 2 single
Module to do automated pentest reporting with SysReptor
0.34 → 0.38
1
33 0 0 single outdated
HTTP library for Python
2.34.2
1
24 1,263 6,748 single
Amazon Web Services version 4 authentication for the Python Requests library
1.4.0
1
19 1 1 single
Persistent cache for requests library
1.3.3
1
31 7 25 single
HTTPS CredSSP authentication with the requests library
2.0.0
1
20 1 3 single
Asynchronous Python HTTP Requests for Humans using Futures
1.0.2 → 1.1.0
1
22 2 1,635 single outdated
GSSAPI authentication handler for python-requests
1.4.0
1
19 1 1 single
Library that adds hardened behavior to python requests
1.3.0
1
22 0 0 single
Hawk authentication strategy for the requests python library
1.2.1
1
15 0 0 single
OAuthlib authentication support for Requests
2.0.0
1
18 41 248 single
PKCS#12 support for the Python requests library
1.27
1
15 1 1 single
Configures the requests library to randomly select a desktop User-Agent
2025.01.19
1
18 0 0 single
Toolbelt of useful classes and functions to be used with requests
1.0.0
1
21 40 641 single
Use requests to talk HTTP via a UNIX domain socket
1.0.1
1
20 1 1 single
WSGI Transport Adapter for Requests
0.4.1
1
14 1 1 single
Import exceptions from potentially bundled packages in requests
1.4.0
1
14 0 0 single
Python tool to find and list requirements of a Python project
1.3.2 → 1.6.0
1
20 0 0 single outdated
Easy to use retry decorator
0.11.8
1
13 2 2 single
SDK for Resend
2.49.1 → 2.50.0
1
21 0 0 single outdated
Commandline utility to resize an image
0.4.0 → 1.1.20
1
18 1 1 single outdated
Python module for mocking out the requests Python library
0.26.2 → 0.26.3
1
25 112 1,331 single outdated
Python library for mocking HTTPX
0.23.1
1
24 37 1,129 single
Python RESTfly API Library Framework
2.0.3
1
26 1 1 single
Restricted execution environment for Python to run untrusted code
8.5
1
18 0 0 single
ReStructuredText viewer
3.0.2
1
22 0 0 single
Deep Face Detection Library for Python
0.0.17 → 0.0.19
1
24 1 1 single outdated
Retry decorator
0.9.5
1
18 2 2 single
Retry potentially transient HTTP errors in Python
1.4.0 → 1.5.0
1
22 0 0 single outdated
Make your functions return something meaningful, typed, and safe
0.29.0
1
29 0 0 single
Commonly consumed code commodities for Python
1.0.0
1
19 0 0 single
Reverse geocode the given latitude/longitude
1.6.6
1
18 1 1 single
Library to decode and encode radio frequency signals
4.3.0
1
19 0 0 single
Opinionated Python RFC3161 Client
1.0.9
1
20 2 7 single
Format dates according to the RFC 3339
6.2
1
13 2 2 single
Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
1.3.8
1
13 3 143 single
RFC 7464 is a proposed standard for streaming JSON documents
17.7.0
1
14 0 0 single
Module for RFC8785 (JSON Canonicalization Scheme)
0.1.4
1
17 2 6 single
RFK101 Proximity card reader over Ethernet
0.0.1
1
16 0 0 single
Library and CLI tools for interacting with RFlink 433MHz transceiver
0.0.68
1
20 0 0 single
RGB conversion tool written in Python for Philips Hue
0.5-unstable-2025-12-16
1
16 1 2 single
Linux C libraries and Python modules for manipulating GPIO
0.2.2
1
13 0 0 single
Render rich text, tables, progress bars, syntax highlighting, markdown and more to the terminal
15.0.0
1
21 207 4,073 single
Format argparse help output using rich
1.8.0
1
18 4 69 single
Library to help formatting argparse
0.3.1.4
1
18 0 0 single
Module to format click help output nicely with rich
1.9.9
1
20 7 33 single
Ready-made rich tables for various purposes
0.10.0
1
29 1 1 single
Define custom styles and themes for use with rich
0.11.0
1
18 1 1 single
Module for Riden RD power supplies
1.2.1
1
21 1 1 single
Data cleaning and validation functions for names, languages, identifiers, etc
1.8.2 → 2.5.0
1
30 0 0 single outdated
Library to communicate with Ring Door Bell
0.9.14
1
32 0 0 single
Create STAC Items from raster datasets
0.12.0
1
20 0 0 single
Small and versatile library to retry failed operations using different backoff strategies
0.3.1
1
14 0 0 single
Formal RISC-V architecture model in Python
0.6.6
1
19 0 0 single
Python client to access RitAssist and FleetGO API
0.9.3
1
17 0 0 single
Framework for comparison of experimental measurements from high-energy particle colliders to theory predictions
4.1.3
1
18 0 0 single
Library for interacting with the Rejseplanen API
0.3.6
1
14 0 0 single
QuantiPhy support for RKM codes
1.0
1
17 1 2 single
Library of reinforcement learning building blocks in JAX
0.1.9
1
27 0 0 single
Reinforcement Learning / AI Bots in Card (Poker) Games - Blackjack, Leduc, Texas, DouDizhu, Mahjong, UNO
1.0.7
1
22 1 5 single
ReMarkable Cloud Library
0.4.2
1
19 0 0 single
Render reMarkable documents to PDF
0.2.1-unstable-2023-06-01
1
23 0 0 single
Read v6 .rm files from the reMarkable tablet
0.8.0
1
20 1 1 single
Compact to regular syntax conversion library for RELAX NG schemata
2.7.0
1
14 1 2 single
Python library and command-line tool for loading multi-file RELAX NG schemas from arbitrary URLs, and flattening them into a single RELAX NG schema
1.0.0
1
24 0 0 single
ROADtools common components library
1.7.0
1
21 3 3 single
Azure AD recon
2.0.0
1
27 1 1 single
Azure AD tooling framework
0.0.2
1
19 0 0 single
ROADtools Token eXchange
1.22.1
1
23 1 1 single
Test data generator for Robot Framework
0.10.0
1
20 0 0 single
Access 125+ robot descriptions from the main Python robotics frameworks
3.2.0 → 3.3.0
1
19 1 2 single outdated
Generic test automation framework
7.4.2 → 7.5
1
17 10 11 single outdated
Generic way to create meaningful and easy to use assertions for the Robot Framework libraries
3.5.0
1
18 1 1 single