master · x86_64-linux · a9b81777a697 · generated 2026-10-15T00:56:45Z
102,481packages 37,782unmaintained (36.9%) 41,903single maintainer (40.9%) 9,640team only (9.4%) 8,441broken 12,431outdated (12.1%) 4,939maintainers 85teams 206setup hooks (hidden)
Reset

41,903 packages · page 114 of 420

Package ▼ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Asynchronous Python client for Roku (ECP)
0.19.5
1
27 1 1 single
Python fast on-disk dictionary / RocksDB & SpeeDB Python binding
0.3.29
1
17 0 0 single
Python API wrapper for Rocket.Chat
3.7.1
1
19 0 0 single
Web testing library for Robot Framework
6.9.0
1
24 1 1 single
Tools to ease creating larger test libraries for Robot Framework using Python
4.6.0
1
21 2 4 single
Robot Framework library for working with Excel documents
2.0.1
1
18 0 0 single
Database Library contains utilities meant for Robot Framework
2.4.1 → 2.5.0
1
20 0 0 single outdated
Generic way to create meaningful and easy to use assertions for the Robot Framework libraries
3.0.3 → 5.0.1
1
18 1 1 single outdated
Generic test automation framework
7.4.2 → 7.5
1
17 12 13 single outdated
Access 125+ robot descriptions from the main Python robotics frameworks
3.2.0 → 3.3.0
1
19 1 2 single outdated
Test data generator for Robot Framework
0.10.0
1
20 0 0 single
ROADtools Token eXchange
1.22.1
1
23 2 2 single
Azure AD tooling framework
0.0.2
1
19 0 0 single
Azure AD recon
2.0.0
1
27 2 2 single
ROADtools common components library
1.7.0
1
21 4 4 single
Python library and command-line tool for loading multi-file RELAX NG schemas from arbitrary URLs, and flattening them into a single RELAX NG schema
1.0.0
1
24 0 0 single
Compact to regular syntax conversion library for RELAX NG schemata
2.7.0
1
14 1 2 single
Read v6 .rm files from the reMarkable tablet
0.8.0
1
20 1 2 single
Render reMarkable documents to PDF
0.2.1-unstable-2023-06-01
1
22 1 1 single
ReMarkable Cloud Library
0.4.2
1
19 1 1 single
Reinforcement Learning / AI Bots in Card (Poker) Games - Blackjack, Leduc, Texas, DouDizhu, Mahjong, UNO
1.0.7
1
22 0 0 single
QuantiPhy support for RKM codes
1.0
1
17 1 2 single
Library for interacting with the Rejseplanen API
0.3.6
1
14 0 0 single
Python client to access RitAssist and FleetGO API
0.9.3
1
17 0 0 single
Formal RISC-V architecture model in Python
0.6.6
1
19 0 0 single
Small and versatile library to retry failed operations using different backoff strategies
0.3.1
1
14 1 1 single
Create STAC Items from raster datasets
0.12.0
1
20 0 0 single
Library to communicate with Ring Door Bell
0.9.14
1
32 1 1 single
Data cleaning and validation functions for names, languages, identifiers, etc
1.8.2 → 2.5.0
1
30 0 0 single outdated
Module for Riden RD power supplies
1.2.1
1
21 2 3 single
Define custom styles and themes for use with rich
0.11.0
1
18 1 1 single
Ready-made rich tables for various purposes
0.10.0
1
29 1 1 single
Module to format click help output nicely with rich
1.9.9
1
20 21 170 single
Library to help formatting argparse
0.3.1.4
1
18 1 2 single
Format argparse help output using rich
1.7.2 → 1.8.0
1
18 8 69 single outdated
Render rich text, tables, progress bars, syntax highlighting, markdown and more to the terminal
15.0.0
1
21 389 6,225 single
Linux C libraries and Python modules for manipulating GPIO
0.2.2
1
13 0 0 single
RGB conversion tool written in Python for Philips Hue
0.5-unstable-2025-12-16
1
15 1 2 single
Library and CLI tools for interacting with RFlink 433MHz transceiver
0.0.68
1
20 1 1 single
RFK101 Proximity card reader over Ethernet
0.0.1
1
16 0 0 single
Module for RFC8785 (JSON Canonicalization Scheme)
0.1.4
1
17 3 6 single
RFC 7464 is a proposed standard for streaming JSON documents
17.7.0
1
14 0 0 single
Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
1.3.8
1
13 5 123 single
Format dates according to the RFC 3339
6.2
1
13 2 2 single
Opinionated Python RFC3161 Client
1.0.9
1
20 2 7 single
Library to decode and encode radio frequency signals
4.3.0
1
19 1,185 1,191 single
Reverse geocode the given latitude/longitude
1.6.6
1
18 1 2 single
Commonly consumed code commodities for Python
1.0.0
1
19 1 1 single
Make your functions return something meaningful, typed, and safe
0.29.0
1
29 1 1 single
Retry potentially transient HTTP errors in Python
1.4.0 → 1.5.0
1
22 0 0 single outdated
Retry decorator
0.9.5
1
18 2 3 single
ReStructuredText viewer
3.0.2
1
22 0 0 single
Restricted execution environment for Python to run untrusted code
8.5
1
18 4 4 single
Python RESTfly API Library Framework
2.0.3
1
26 1 3 single
Python library for mocking HTTPX
0.23.1
1
24 1,222 2,521 single
Python module for mocking out the requests Python library
0.26.2 → 0.26.3
1
25 133 2,772 single outdated
Commandline utility to resize an image
0.4.0 → 1.1.20
1
18 1 2 single outdated
SDK for Resend
2.45.0 → 2.49.1
1
20 1 1 single outdated
Easy to use retry decorator
0.11.8
1
13 2 2 single
Python tool to find and list requirements of a Python project
1.3.2 → 1.6.0
1
20 1 1 single outdated
Import exceptions from potentially bundled packages in requests
1.4.0
1
14 0 0 single
WSGI Transport Adapter for Requests
0.4.1
1
14 1 2 single
Use requests to talk HTTP via a UNIX domain socket
1.0.1
1
20 1 2 single
Toolbelt of useful classes and functions to be used with requests
1.0.0
1
21 57 761 single
Configures the requests library to randomly select a desktop User-Agent
2025.01.19
1
18 0 0 single
PKCS#12 support for the Python requests library
1.27
1
15 2 4 single
OAuthlib authentication support for Requests
2.0.0
1
18 54 328 single
Hawk authentication strategy for the requests python library
1.2.1
1
15 2 2 single
Library that adds hardened behavior to python requests
1.3.0
1
22 1 1 single
GSSAPI authentication handler for python-requests
1.4.0
1
19 1 1 single
Asynchronous Python HTTP Requests for Humans using Futures
1.0.2 → 1.1.0
1
22 6 3,084 single outdated
HTTPS CredSSP authentication with the requests library
2.0.0
1
20 1 4 single
Persistent cache for requests library
1.3.3
1
31 17 42 single
Amazon Web Services version 4 authentication for the Python Requests library
1.3.2 → 1.4.0
1
19 1 1 single outdated
HTTP library for Python
2.34.2
1
24 2,972 43,309 single
Module to do automated pentest reporting with SysReptor
0.34 → 0.38
1
33 0 0 single outdated
Toolshed for writing great __repr__ methods quickly and easily
1.0.6
1
13 1 2 single
Reproject astronomical images
0.21.0
1
36 2 4 single
Allows to create QR codes for use with the ReportLab PDF library
0.1.6
1
19 1 1 single
Python client for Replicate
1.1.0b3 → 1.0.7
1
24 0 0 single outdated
Python REPL plugin for automatic time tracking and metrics generated from your programming activity
0.1.6
1
22 0 0 single
Port of the node module path-to-regexp to Python
0.9.0
1
14 1 4 single
Simple regex-based lexer/parser for inline markup
1.4.3
1
13 0 0 single
Tool for automatically reordering python imports
3.18.0 → 3.19.0
1
18 0 0 single outdated
Module to interact with the Reolink IP camera API
0.21.18
1
21 1 1 single
Module to interact with the Reolink IP camera API
0.0.64 → 0053
1
19 0 0 single outdated
Module to interact with Renson endura delta
1.7.2
1
17 1 1 single
Python package with some fonts for the rendercv package
0.5.1
1
17 1 1 single
One canvas API, multiple backends
2.7.2
1
22 0 0 single
Python library to interact with the Renault API
0.5.15 → 0.6.1
1
29 1 1 single outdated
Access zip file content hosted remotely without downloading the full file
0.0.2
1
18 1 2 single
Python module to access single members of a zip archive without downloading the full content
0.12.5 → 0.12.6
1
19 2 4 single outdated
Remote vanilla PDB (over TCP sockets)
2.1.0
1
13 1 1 single
Pythonic, lightweight and websocket-based webui library
2022.7.27
1
21 0 0 single
Tool to remove background from images
2.0.85
1
27 1 1 single
Sphinx extension for changelog manipulation
2.1.1
1
15 1 1 single
Templating library able to output odt and pdf files
0.11.1 → 1.0.0
1
17 2 2 single outdated
Nested Object Models in Python
0.7.3
1
21 0 0 single
Python bindings to the Rust regress crate, exposing ECMA regular expressions
2026.9.1
1
15 1 2 single
Alternative regular expression module, to replace re
2026.7.11 → 2026.9.29
1
17 114 5,491 single outdated