master · x86_64-linux · e7fccb1ad3ed · generated 2026-10-17T01:00:33Z
102,550packages 37,779unmaintained (36.8%) 41,932single maintainer (40.9%) 9,663team only (9.4%) 8,445broken 11,466outdated (11.2%) 4,941maintainers 85teams 207setup hooks (hidden)
Reset

41,932 packages · page 193 of 420

Package ▼ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Job scheduling capabilities for RQ (Redis Queue)
0.14.0
1
20 0 0 single
Library for creating background jobs and processing them
2.10 → 2.12.0
1
24 5 11 single outdated
Remote Python Call (RPyC), a transparent and symmetric RPC library
6.0.2
1
18 5 8 single
Python interface to R
3.6.5 → 3.6.7
1
24 1 2 single outdated
Python interface to R
3.6.7 → 3.6.9
1
18 1 1 single outdated
Python Lex/Yacc that works with RPython
0.7.8
1
16 3 7 single
Raspberry Pi LCD library for the widely used Hitachi HD44780 controller
1.4.0
1
13 0 0 single
Python module to control the GPIO on a Raspberry Pi
0.6
1
17 0 0 single
Python module to control the GPIO on a Raspberry Pi
0.7.1
1
13 2 2 single
Python library to detect bad power supply on Raspberry Pi
0.1.0
1
17 0 0 single
Python bindings to Rust's persistent data structures
2026.6.3 → 2026.9.1
1
18 4 4,828 single outdated
RPC framework and message specification for rigetti Quantum Cloud services
3.10.0 → 3.11.0
1
23 1 1 single outdated
Simple tool allowing you to create, modify and extract Ren'Py Archive (.rpa/.rpi) files
1.0.0
1
16 0 0 single
Python package for working with quaternions
1.3.2
1
19 1 1 single
Module to access for ROVA calendars
0.4.1
1
17 0 0 single
Python API to RouterBoard devices produced by MikroTik
0.21.0
1
18 0 0 single
Python ROUGE Implementation
0.1.2
1
21 1 4 single
ROS package library for Python
1.6.3
1
21 0 0 single
Pure Python library to read, modify, convert, and write rosbag files
0.11.0 → 0.11.8
1
24 0 0 single outdated
Show information about files in different file formats
1.13.13
1
19 0 0 single
Tool to search for gadgets in binaries to facilitate ROP exploitation
7.7
1
17 1 1 single
Python library to interface with the Roon API
0.1.6
1
20 0 0 single
Library to control Wi-Fi enabled ROMY vacuum cleaners
0.0.10
1
17 0 0 single
Integer to Roman numerals converter
5.2
1
17 2 2 single
Lightweight library to deal with 3D rotations in PyTorch
1.6.0 → 1.6.1
1
19 0 0 single outdated
Asynchronous Python client for Roku (ECP)
0.19.5
1
27 0 0 single
Python fast on-disk dictionary / RocksDB & SpeeDB Python binding
0.3.29
1
17 0 0 single
Python API wrapper for Rocket.Chat
3.7.1
1
19 0 0 single
Web testing library for Robot Framework
6.9.0
1
24 1 1 single
Tools to ease creating larger test libraries for Robot Framework using Python
4.6.0
1
21 2 4 single
Robot Framework library for working with Excel documents
2.0.1
1
18 0 0 single
Database Library contains utilities meant for Robot Framework
2.4.1 → 2.5.0
1
20 0 0 single outdated
Generic way to create meaningful and easy to use assertions for the Robot Framework libraries
3.5.0
1
18 1 1 single
Generic test automation framework
7.4.2 → 7.5
1
17 10 11 single outdated
Access 125+ robot descriptions from the main Python robotics frameworks
3.2.0 → 3.3.0
1
19 1 2 single outdated
Test data generator for Robot Framework
0.10.0
1
20 0 0 single
ROADtools Token eXchange
1.22.1
1
23 1 1 single
Azure AD tooling framework
0.0.2
1
19 0 0 single
Azure AD recon
2.0.0
1
27 1 1 single
ROADtools common components library
1.7.0
1
21 3 3 single
Python library and command-line tool for loading multi-file RELAX NG schemas from arbitrary URLs, and flattening them into a single RELAX NG schema
1.0.0
1
24 0 0 single
Compact to regular syntax conversion library for RELAX NG schemata
2.7.0
1
14 1 2 single
Read v6 .rm files from the reMarkable tablet
0.8.0
1
20 1 1 single
Render reMarkable documents to PDF
0.2.1-unstable-2023-06-01
1
23 0 0 single
ReMarkable Cloud Library
0.4.2
1
19 0 0 single
Reinforcement Learning / AI Bots in Card (Poker) Games - Blackjack, Leduc, Texas, DouDizhu, Mahjong, UNO
1.0.7
1
22 1 5 single
Library of reinforcement learning building blocks in JAX
0.1.9
1
27 0 0 single
QuantiPhy support for RKM codes
1.0
1
17 1 2 single
Library for interacting with the Rejseplanen API
0.3.6
1
14 0 0 single
Framework for comparison of experimental measurements from high-energy particle colliders to theory predictions
4.1.3
1
18 0 0 single
Python client to access RitAssist and FleetGO API
0.9.3
1
17 0 0 single
Formal RISC-V architecture model in Python
0.6.6
1
19 0 0 single
Small and versatile library to retry failed operations using different backoff strategies
0.3.1
1
14 0 0 single
Create STAC Items from raster datasets
0.12.0
1
20 0 0 single
Library to communicate with Ring Door Bell
0.9.14
1
32 0 0 single
Data cleaning and validation functions for names, languages, identifiers, etc
1.8.2 → 2.5.0
1
30 0 0 single outdated
Module for Riden RD power supplies
1.2.1
1
21 1 1 single
Define custom styles and themes for use with rich
0.11.0
1
18 1 1 single
Ready-made rich tables for various purposes
0.10.0
1
29 1 1 single
Module to format click help output nicely with rich
1.9.9
1
20 7 33 single
Library to help formatting argparse
0.3.1.4
1
18 0 0 single
Format argparse help output using rich
1.8.0
1
18 4 69 single
Render rich text, tables, progress bars, syntax highlighting, markdown and more to the terminal
15.0.0
1
21 207 4,073 single
Linux C libraries and Python modules for manipulating GPIO
0.2.2
1
13 0 0 single
RGB conversion tool written in Python for Philips Hue
0.5-unstable-2025-12-16
1
16 1 2 single
Library and CLI tools for interacting with RFlink 433MHz transceiver
0.0.68
1
20 0 0 single
RFK101 Proximity card reader over Ethernet
0.0.1
1
16 0 0 single
Module for RFC8785 (JSON Canonicalization Scheme)
0.1.4
1
17 2 6 single
RFC 7464 is a proposed standard for streaming JSON documents
17.7.0
1
14 0 0 single
Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
1.3.8
1
13 3 143 single
Format dates according to the RFC 3339
6.2
1
13 2 2 single
Opinionated Python RFC3161 Client
1.0.9
1
20 2 7 single
Library to decode and encode radio frequency signals
4.3.0
1
19 0 0 single
Reverse geocode the given latitude/longitude
1.6.6
1
18 1 1 single
Commonly consumed code commodities for Python
1.0.0
1
19 0 0 single
Make your functions return something meaningful, typed, and safe
0.29.0
1
29 0 0 single
Retry potentially transient HTTP errors in Python
1.4.0 → 1.5.0
1
22 0 0 single outdated
Retry decorator
0.9.5
1
18 2 2 single
Deep Face Detection Library for Python
0.0.17 → 0.0.19
1
24 1 1 single outdated
ReStructuredText viewer
3.0.2
1
22 0 0 single
Restricted execution environment for Python to run untrusted code
8.5
1
18 0 0 single
Python RESTfly API Library Framework
2.0.3
1
26 1 1 single
Python library for mocking HTTPX
0.23.1
1
24 37 1,129 single
Python module for mocking out the requests Python library
0.26.2 → 0.26.3
1
25 112 1,331 single outdated
Commandline utility to resize an image
0.4.0 → 1.1.20
1
18 1 1 single outdated
SDK for Resend
2.49.1 → 2.50.0
1
21 0 0 single outdated
Easy to use retry decorator
0.11.8
1
13 2 2 single
Python tool to find and list requirements of a Python project
1.3.2 → 1.6.0
1
20 0 0 single outdated
Import exceptions from potentially bundled packages in requests
1.4.0
1
14 0 0 single
WSGI Transport Adapter for Requests
0.4.1
1
14 1 1 single
Use requests to talk HTTP via a UNIX domain socket
1.0.1
1
20 1 1 single
Toolbelt of useful classes and functions to be used with requests
1.0.0
1
21 40 641 single
Configures the requests library to randomly select a desktop User-Agent
2025.01.19
1
18 0 0 single
PKCS#12 support for the Python requests library
1.27
1
15 1 1 single
OAuthlib authentication support for Requests
2.0.0
1
18 41 248 single
Hawk authentication strategy for the requests python library
1.2.1
1
15 0 0 single
Library that adds hardened behavior to python requests
1.3.0
1
22 0 0 single
GSSAPI authentication handler for python-requests
1.4.0
1
19 1 1 single
Asynchronous Python HTTP Requests for Humans using Futures
1.0.2 → 1.1.0
1
22 2 1,635 single outdated
HTTPS CredSSP authentication with the requests library
2.0.0
1
20 1 3 single