master · x86_64-linux · d60a837d2489 · generated 2026-10-11T00:54:24Z
102,294packages 37,810unmaintained (37.0%) 41,855single maintainer (40.9%) 9,526team only (9.3%) 8,411broken 12,427outdated (12.1%) 4,922maintainers 85teams 206setup hooks (hidden)
Reset

11,643 packages · page 29 of 117

Package ▼ Version Maintainers # Teams Deps Used by Used by (transitive) Status
Python fast on-disk dictionary / RocksDB & SpeeDB Python binding
0.3.29
1
17 0 0 single
Python API wrapper for Rocket.Chat
3.7.1
1
19 0 0 single
Modern, multi-threaded and extensible web server
1.2.5
0
13 0 0 unmaintained
Python unittest test suite for Robot Framework
3.0.1
0
17 0 0 unmaintained
Tool for checking that Robot Framework test cases have expected statuses and log messages
4.1.1
0
17 1 2 unmaintained
SSHLibrary is a Robot Framework test library for SSH and SFTP
3.8.0
0
16 0 0 unmaintained
Web testing library for Robot Framework
6.9.0
1
24 1 1 single
Web testing library for Robot Framework
3.0.0
0
14 0 0 unmaintained
Robot Framework keyword library wrapper around the HTTP client library requests
0.9.7
0
17 0 0 unmaintained
Tools to ease creating larger test libraries for Robot Framework using Python
4.6.0
1
21 2 4 single
Robot Framework library for working with Excel documents
2.0.1
1
18 0 0 single
Database Library contains utilities meant for Robot Framework
2.4.1 → 2.5.0
1
20 0 0 single outdated
Generic way to create meaningful and easy to use assertions for the Robot Framework libraries
3.0.3 → 5.0.1
1
18 1 1 single outdated
Generic test automation framework
7.4.2 → 7.5
1
17 10 11 single outdated
Library for detecting if a HTTP User Agent header is likely to be a bot
0.4
0
14 0 0 unmaintained
Access 125+ robot descriptions from the main Python robotics frameworks
3.2.0
1
19 1 2 single
Test data generator for Robot Framework
0.10.0
1
20 0 0 single
ROADtools Token eXchange
1.22.1
1
23 1 1 single
Azure AD tooling framework
0.0.2
1
19 0 0 single
Azure AD recon
2.0.0
1
27 1 1 single
ROADtools common components library
1.7.0
1
21 3 3 single
Cryptography-based networking stack for wide-area networks
1.5.7
3
21 4 4 maintained unfree
Python library and command-line tool for loading multi-file RELAX NG schemas from arbitrary URLs, and flattening them into a single RELAX NG schema
1.0.0
1
24 0 0 single
Compact to regular syntax conversion library for RELAX NG schemata
2.7.0
1
14 1 2 single
Calculate root-mean-square deviation (RMSD) between two sets of cartesian coordinates
1.7.0
2
19 0 0 maintained
Read v6 .rm files from the reMarkable tablet
0.8.0
1
20 1 1 single
Render reMarkable documents to PDF
0.2.1-unstable-2023-06-01
1
22 0 0 single
ReMarkable Cloud Library
0.4.2
1
19 0 0 single
RLP serialization library
4.1.0 → 5.0.0
0
20 5 8 unmaintained outdated
Reinforcement Learning / AI Bots in Card (Poker) Games - Blackjack, Leduc, Texas, DouDizhu, Mahjong, UNO
1.0.7
1
22 1 5 single
Library of reinforcement learning building blocks in JAX
0.1.9
1
27 0 0 single
QuantiPhy support for RKM codes
1.0
1
17 1 2 single
Module to minify Javascript
1.2.5 → 1.3.0
0
13 1 2 unmaintained outdated
Library for interacting with the Rejseplanen API
0.3.6
1
14 0 0 single
Framework for comparison of experimental measurements from high-energy particle colliders to theory predictions
4.1.3
1
18 0 0 single
Python client to access RitAssist and FleetGO API
0.9.3
1
17 0 0 single
Formal RISC-V architecture model in Python
0.6.6
1
19 0 0 single
ISA coverage extraction tool
0.18.0
0
22 1 1 unmaintained
RISC-V configuration validator
3.18.3
0
20 1 1 unmaintained
RISC-V Architectural Test Framework
1.25.3
0
16 0 0 unmaintained
Lean Persistent Homology Library for Python
0.6.15
0
23 1 1 unmaintained
Small and versatile library to retry failed operations using different backoff strategies
0.3.1
1
14 0 0 single
Parsing library for RIPE Atlas measurements results
1.3.1
0
17 0 0 unmaintained
Python client library for RIPE ATLAS API
2.0.0
0
23 0 0 unmaintained
Geospatial xarray extension powered by rasterio
0.23.0
7 24 1 1 team-only
User friendly Rasterio plugin to read raster datasets
9.4.7 → 9.4.12
7 35 0 0 team-only outdated
Create STAC Items from raster datasets
0.12.0
1
20 0 0 single
Library to communicate with Ring Door Bell
0.9.14
1
32 0 0 single
Data cleaning and validation functions for names, languages, identifiers, etc
1.8.2 → 2.5.0
1
30 0 0 single outdated
Module for Riden RD power supplies
1.2.1
1
21 1 1 single
Rich toolkit for building command-line applications
0.20.1 → 0.20.6
0
22 2 564 unmaintained outdated
Define custom styles and themes for use with rich
0.11.0
1
18 1 1 single
Ready-made rich tables for various purposes
0.10.0
1
29 1 1 single
Beautiful reStructuredText renderer for rich
2.1.0 → 2.2.0
0
19 1 14 unmaintained outdated
Rich-compatible library for writing pixel images and ASCII art to the terminal
3.0.1
0
21 0 0 unmaintained
Module to format click help output nicely with rich
1.9.9
1
20 7 30 single
Library to help formatting argparse
0.3.1.4
1
18 0 0 single
Format argparse help output using rich
1.7.2 → 1.8.0
1
18 4 69 single outdated
Render rich text, tables, progress bars, syntax highlighting, markdown and more to the terminal
15.0.0
1
21 206 3,876 single
Linux C libraries and Python modules for manipulating GPIO
0.2.2
1
13 0 0 single
RGB conversion tool written in Python for Philips Hue
0.5-unstable-2025-12-16
1
15 1 2 single
Library and CLI tools for interacting with RFlink 433MHz transceiver
0.0.68
1
20 0 0 single
RFK101 Proximity card reader over Ethernet
0.0.1
1
16 0 0 single
Swiss Army knife of sub-GHz ISM band radio
3.0.0
0
22 0 0 unmaintained
Module for RFC8785 (JSON Canonicalization Scheme)
0.1.4
1
17 2 4 single
RFC 7464 is a proposed standard for streaming JSON documents
17.7.0
1
14 0 0 single
Python implementation of the Happy Eyeballs Algorithm
0.1.0
0
14 0 0 unmaintained
Helper functions to syntactically validate strings according to RFC 3987
1.1.0
0
18 2 139 unmaintained
Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
1.3.8
1
13 3 142 single
Pure python rfc3986 validator
0.1.1
0
16 2 139 unmaintained
Validating URI References per RFC 3986
2.0.0
0
15 5 383 unmaintained
RFC 3339 validator for Python
0.1.4
0
17 6 693 unmaintained
Format dates according to the RFC 3339
6.2
1
13 2 2 single
Opinionated Python RFC3161 Client
1.0.9
1
20 2 5 single
Library to decode and encode radio frequency signals
4.3.0
1
19 0 0 single
Reverse geocode the given latitude/longitude
1.6.6
1
18 1 1 single
Tool for compliance with the REUSE Initiative recommendations
6.2.0
2
32 0 0 maintained
Commonly consumed code commodities for Python
1.0.0
1
19 0 0 single
Make your functions return something meaningful, typed, and safe
0.29.0
1
29 0 0 single
General-purpose retrying library
1.4.2
0
17 4 10 unmaintained
Retry potentially transient HTTP errors in Python
1.4.0 → 1.5.0
1
22 0 0 single outdated
Retry decorator
0.9.5
1
18 2 2 single
Decorator for retrying when exceptions occur
1.1.1
0
14 0 0 unmaintained
Easy to use retry decorator
0.9.2 → 0.9.5
0
18 2 3 unmaintained outdated
Deep Face Detection Library for Python
0.0.17 → 0.0.19
1
24 1 1 single outdated
Python driver library for the RethinkDB database server
2.4.10.post1
0
18 0 0 unmaintained
High level wrapper of resvg for python
0.5.0
0
19 0 0 unmaintained
Rust-like result type for Python
0.17.0
0
19 1 2 unmaintained
ReStructuredText viewer
3.0.2
1
22 0 0 single
reStructuredText linter
2.0.2
0
18 3 6 unmaintained
Restricted execution environment for Python to run untrusted code
8.5
1
18 0 0 single
Python RESTfly API Library Framework
2.0.3
1
26 1 1 single
Python library for mocking HTTPX
0.23.1
1
24 37 994 single
Python module for mocking out the requests Python library
0.26.2 → 0.26.3
1
25 112 1,327 single outdated
Resolve abstract dependencies into concrete ones
1.2.1
0
18 3 13 unmaintained
Correct way to resize images or tensors. For Numpy or Pytorch (differentiable
0.0.2
1 15 0 0 team-only
Commandline utility to resize an image
0.4.0 → 1.1.20
1
18 1 1 single outdated
SDK for Resend
2.45.0 → 2.49.1
1
20 0 0 single outdated
Efficient signal resampling
0.4.3
0
21 3 36 unmaintained
Python bindings for `rerun` (an interactive visualization tool for stream data)
0.38.1
2
37 0 0 maintained